summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-12 05:31:18 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-12 05:31:18 +0000
commitfa71d536b489df703f697134e5bfc04068c3a6e0 (patch)
tree8579291fcac87a9b0c81c7c95db413f867f9c30c /dev-python/gitdb
parentbump, rm old (diff)
downloadgentoo-2-fa71d536b489df703f697134e5bfc04068c3a6e0.tar.gz
gentoo-2-fa71d536b489df703f697134e5bfc04068c3a6e0.tar.bz2
gentoo-2-fa71d536b489df703f697134e5bfc04068c3a6e0.zip
bump, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/gitdb')
-rw-r--r--dev-python/gitdb/ChangeLog8
-rw-r--r--dev-python/gitdb/gitdb-0.6.0.ebuild27
-rw-r--r--dev-python/gitdb/gitdb-0.6.3.ebuild30
3 files changed, 37 insertions, 28 deletions
diff --git a/dev-python/gitdb/ChangeLog b/dev-python/gitdb/ChangeLog
index f342655b7fb6..04a1c45d6de1 100644
--- a/dev-python/gitdb/ChangeLog
+++ b/dev-python/gitdb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gitdb
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gitdb/ChangeLog,v 1.6 2015/01/06 10:57:58 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gitdb/ChangeLog,v 1.7 2015/01/12 05:31:18 idella4 Exp $
+
+*gitdb-0.6.3 (12 Jan 2015)
+
+ 12 Jan 2015; Ian Delaney <idella4@gentoo.org> +gitdb-0.6.3.ebuild,
+ -gitdb-0.6.0.ebuild:
+ bump, rm old
*gitdb-0.6.1 (06 Jan 2015)
diff --git a/dev-python/gitdb/gitdb-0.6.0.ebuild b/dev-python/gitdb/gitdb-0.6.0.ebuild
deleted file mode 100644
index fabf9f0db522..000000000000
--- a/dev-python/gitdb/gitdb-0.6.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gitdb/gitdb-0.6.0.ebuild,v 1.1 2014/11/18 10:11:54 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
-
-inherit distutils-r1
-
-DESCRIPTION="GitDB is a pure-Python git object database"
-HOMEPAGE="
- https://github.com/gitpython-developers/gitdb
- http://pypi.python.org/pypi/gitdb"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/async-0.6[${PYTHON_USEDEP}]
- >=dev-python/smmap-0.8.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/gitdb/gitdb-0.6.3.ebuild b/dev-python/gitdb/gitdb-0.6.3.ebuild
new file mode 100644
index 000000000000..a2748a816693
--- /dev/null
+++ b/dev-python/gitdb/gitdb-0.6.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gitdb/gitdb-0.6.3.ebuild,v 1.1 2015/01/12 05:31:18 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="GitDB is a pure-Python git object database"
+HOMEPAGE="
+ https://github.com/gitpython-developers/gitdb
+ http://pypi.python.org/pypi/gitdb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-vcs/git
+ >=dev-python/smmap-0.8.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+# Testsuite appears to require files from a git repo
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}