summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-26 17:50:00 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-26 17:50:00 +0000
commit0475fc621d949390726a632199e80bea7674b64c (patch)
treeca2af9c3a2349eea1146adf0265dc4d005189881 /dev-python/gtkspell-python
parentConvert to gnome-python-common-r1. (diff)
downloadgentoo-2-0475fc621d949390726a632199e80bea7674b64c.tar.gz
gentoo-2-0475fc621d949390726a632199e80bea7674b64c.tar.bz2
gentoo-2-0475fc621d949390726a632199e80bea7674b64c.zip
Convert to gnome-python-common-r1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/gtkspell-python')
-rw-r--r--dev-python/gtkspell-python/ChangeLog10
-rw-r--r--dev-python/gtkspell-python/gtkspell-python-2.25.3-r1.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-python/gtkspell-python/ChangeLog b/dev-python/gtkspell-python/ChangeLog
index f2f12a875d32..10013de7030e 100644
--- a/dev-python/gtkspell-python/ChangeLog
+++ b/dev-python/gtkspell-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gtkspell-python
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gtkspell-python/ChangeLog,v 1.22 2013/04/26 02:58:00 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gtkspell-python/ChangeLog,v 1.23 2014/05/26 17:50:00 mgorny Exp $
+
+*gtkspell-python-2.25.3-r1 (26 May 2014)
+
+ 26 May 2014; Michał Górny <mgorny@gentoo.org>
+ +gtkspell-python-2.25.3-r1.ebuild:
+ Convert to gnome-python-common-r1.
26 Apr 2013; Patrick Lauer <patrick@gentoo.org> gtkspell-python-2.25.3.ebuild:
Automake 1.13 fix
diff --git a/dev-python/gtkspell-python/gtkspell-python-2.25.3-r1.ebuild b/dev-python/gtkspell-python/gtkspell-python-2.25.3-r1.ebuild
new file mode 100644
index 000000000000..53699323ab70
--- /dev/null
+++ b/dev-python/gtkspell-python/gtkspell-python-2.25.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gtkspell-python/gtkspell-python-2.25.3-r1.ebuild,v 1.1 2014/05/26 17:50:00 mgorny Exp $
+
+EAPI="5"
+
+GNOME_ORG_MODULE="gnome-python-extras"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome-python-common-r1
+
+DESCRIPTION="GtkSpell bindings for Python"
+# The LICENSE with gtkspell-3 is LGPL and there is no way to express this in
+# an ebuild, currently. Punt till we actually have to face the issue.
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND="app-text/gtkspell:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ gnome-base/gnome-common"
+# eautoreconf needs gnome-base/gnome-common
+
+EXAMPLES=( examples/gtkspell/. )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-libs.patch" #344231
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+ gnome-python-common-r1_src_prepare
+}