summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-26 19:31:09 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-26 19:31:09 +0000
commit6b30981309b1502df263193c0517eb7f6ffbc331 (patch)
treed9aeff43eac7ad052fdace7b3562293c177f46e9 /dev-python/hachoir-core
parentDelete older ebuild. (diff)
downloadgentoo-2-6b30981309b1502df263193c0517eb7f6ffbc331.tar.gz
gentoo-2-6b30981309b1502df263193c0517eb7f6ffbc331.tar.bz2
gentoo-2-6b30981309b1502df263193c0517eb7f6ffbc331.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 15841-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/hachoir-core')
-rw-r--r--dev-python/hachoir-core/ChangeLog10
-rw-r--r--dev-python/hachoir-core/hachoir-core-1.3.3.ebuild31
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/hachoir-core/ChangeLog b/dev-python/hachoir-core/ChangeLog
index 57c9ae4960c4..11ba074f2d11 100644
--- a/dev-python/hachoir-core/ChangeLog
+++ b/dev-python/hachoir-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/hachoir-core
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hachoir-core/ChangeLog,v 1.5 2008/08/12 08:07:13 cedk Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hachoir-core/ChangeLog,v 1.6 2010/03/26 19:31:09 arfrever Exp $
+
+*hachoir-core-1.3.3 (26 Mar 2010)
+
+ 26 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -hachoir-core-1.0.1.ebuild, +hachoir-core-1.3.3.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
12 Aug 2008; Cédric Krier <cedk@gentoo.org> hachoir-core-1.0.1.ebuild,
hachoir-core-1.1.ebuild:
diff --git a/dev-python/hachoir-core/hachoir-core-1.3.3.ebuild b/dev-python/hachoir-core/hachoir-core-1.3.3.ebuild
new file mode 100644
index 000000000000..0205d5e01224
--- /dev/null
+++ b/dev-python/hachoir-core/hachoir-core-1.3.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hachoir-core/hachoir-core-1.3.3.ebuild,v 1.1 2010/03/26 19:31:09 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Core of Hachoir framework: parse and edit binary files"
+HOMEPAGE="http://bitbucket.org/haypo/hachoir/wiki/hachoir-core http://pypi.python.org/pypi/hachoir-core"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="${PN/-/_}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test_doc.py
+ }
+ python_execute_function testing
+}