summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-18 07:04:53 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-18 07:04:53 +0000
commit9557c1fc1400849c72f8c5410a056c9eb20ee1cb (patch)
tree33d6a77b312427467fb7bd303114a6ef30f9fa13 /dev-python/html5lib
parentrevbump, migrate -> distutils-r1, bump; add full py3 support (diff)
downloadgentoo-2-9557c1fc1400849c72f8c5410a056c9eb20ee1cb.tar.gz
gentoo-2-9557c1fc1400849c72f8c5410a056c9eb20ee1cb.tar.bz2
gentoo-2-9557c1fc1400849c72f8c5410a056c9eb20ee1cb.zip
Version bump. Upstream dropped 2.5 support and added 3.2+ support, update HOMEPAGE to github, and use nose for tests.
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/ChangeLog8
-rw-r--r--dev-python/html5lib/html5lib-1.0_beta1.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/html5lib/ChangeLog b/dev-python/html5lib/ChangeLog
index 04f276d11bd6..04aebcff51ca 100644
--- a/dev-python/html5lib/ChangeLog
+++ b/dev-python/html5lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/html5lib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/ChangeLog,v 1.16 2013/05/24 15:19:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/ChangeLog,v 1.17 2013/06/18 07:04:53 radhermit Exp $
+
+*html5lib-1.0_beta1 (18 Jun 2013)
+
+ 18 Jun 2013; Tim Harder <radhermit@gentoo.org> +html5lib-1.0_beta1.ebuild:
+ Version bump. Upstream dropped 2.5 support and added 3.2+ support, update
+ HOMEPAGE to github, and use nose for tests.
24 May 2013; Alexis Ballier <aballier@gentoo.org> html5lib-0.95-r1.ebuild:
keyword ~amd64-fbsd, bug #461346
diff --git a/dev-python/html5lib/html5lib-1.0_beta1.ebuild b/dev-python/html5lib/html5lib-1.0_beta1.ebuild
new file mode 100644
index 000000000000..ef228a2f1a5e
--- /dev/null
+++ b/dev-python/html5lib/html5lib-1.0_beta1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/html5lib-1.0_beta1.ebuild,v 1.1 2013/06/18 07:04:53 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy{1_9,2_0} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+MY_P=${PN}-${PV/_beta/b}
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ http://pypi.python.org/pypi/html5lib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}