summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-20 13:24:37 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-20 13:24:37 +0000
commitc263d87156edfea826a01bc58b32ae14ad8ccd2d (patch)
tree36e01deb48de7a1ac0f2fa5f4907682caef126c5 /dev-python/ipy
parentFix typo (diff)
downloadgentoo-2-c263d87156edfea826a01bc58b32ae14ad8ccd2d.tar.gz
gentoo-2-c263d87156edfea826a01bc58b32ae14ad8ccd2d.tar.bz2
gentoo-2-c263d87156edfea826a01bc58b32ae14ad8ccd2d.zip
rm old impls, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/ipy')
-rw-r--r--dev-python/ipy/ChangeLog6
-rw-r--r--dev-python/ipy/ipy-0.76-r1.ebuild36
-rw-r--r--dev-python/ipy/ipy-0.76.ebuild37
-rw-r--r--dev-python/ipy/ipy-0.81.ebuild4
4 files changed, 7 insertions, 76 deletions
diff --git a/dev-python/ipy/ChangeLog b/dev-python/ipy/ChangeLog
index be64677e19e5..ad77a8f9ddca 100644
--- a/dev-python/ipy/ChangeLog
+++ b/dev-python/ipy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/ipy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ChangeLog,v 1.43 2014/11/25 09:16:57 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ChangeLog,v 1.44 2014/12/20 13:24:37 idella4 Exp $
+
+ 20 Dec 2014; Ian Delaney <idella4@gentoo.org> -ipy-0.76-r1.ebuild,
+ -ipy-0.76.ebuild, ipy-0.81.ebuild:
+ rm old impls, rm old
25 Nov 2014; Pacho Ramos <pacho@gentoo.org> ipy-0.81.ebuild:
Support python 3.4
diff --git a/dev-python/ipy/ipy-0.76-r1.ebuild b/dev-python/ipy/ipy-0.76-r1.ebuild
deleted file mode 100644
index e925afcdc8ba..000000000000
--- a/dev-python/ipy/ipy-0.76-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.76-r1.ebuild,v 1.6 2014/03/31 21:19:47 mgorny Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-inherit distutils-r1
-
-MY_PN="IPy"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
-HOMEPAGE="https://github.com/haypo/python-ipy/wiki http://pypi.python.org/pypi/IPy"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( ChangeLog README )
-
-python_test() {
- # doctests for py3 unaltered read py2 files from "${S}" causing total failure
- cp -r test_doc.py README test "${BUILD_DIR}" || die
- pushd "${BUILD_DIR}" > /dev/null || die
- "${PYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
- "${PYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
- popd > /dev/null || die
-}
diff --git a/dev-python/ipy/ipy-0.76.ebuild b/dev-python/ipy/ipy-0.76.ebuild
deleted file mode 100644
index 653824ea6828..000000000000
--- a/dev-python/ipy/ipy-0.76.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.76.ebuild,v 1.1 2013/03/26 03:41:40 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4"
-
-inherit distutils
-
-MY_PN="IPy"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
-HOMEPAGE="https://github.com/haypo/python-ipy/wiki http://pypi.python.org/pypi/IPy"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="ChangeLog README"
-PYTHON_MODNAME="IPy.py"
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_IPy.py
- }
- python_execute_function testing
-}
diff --git a/dev-python/ipy/ipy-0.81.ebuild b/dev-python/ipy/ipy-0.81.ebuild
index fe86500cacff..ccc3929ef80d 100644
--- a/dev-python/ipy/ipy-0.81.ebuild
+++ b/dev-python/ipy/ipy-0.81.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.81.ebuild,v 1.4 2014/11/25 09:16:57 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.81.ebuild,v 1.5 2014/12/20 13:24:37 idella4 Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1