summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-26 02:38:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-26 02:38:37 +0000
commit1ece62cedbaf53b762e92d57701ccf354d1f49d4 (patch)
treec2e3a7061a30130d10ee94e9e06e16d9edf38537 /dev-python/irc
parentBump (diff)
downloadgentoo-2-1ece62cedbaf53b762e92d57701ccf354d1f49d4.tar.gz
gentoo-2-1ece62cedbaf53b762e92d57701ccf354d1f49d4.tar.bz2
gentoo-2-1ece62cedbaf53b762e92d57701ccf354d1f49d4.zip
Bump
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/irc')
-rw-r--r--dev-python/irc/ChangeLog7
-rw-r--r--dev-python/irc/irc-8.5.1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/irc/ChangeLog b/dev-python/irc/ChangeLog
index cb6080694cab..b7a365d6b57d 100644
--- a/dev-python/irc/ChangeLog
+++ b/dev-python/irc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/irc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/ChangeLog,v 1.13 2013/08/19 15:47:00 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/ChangeLog,v 1.14 2013/08/26 02:38:37 patrick Exp $
+
+*irc-8.5.1 (26 Aug 2013)
+
+ 26 Aug 2013; Patrick Lauer <patrick@gentoo.org> +irc-8.5.1.ebuild:
+ Bump
*irc-8.5 (19 Aug 2013)
diff --git a/dev-python/irc/irc-8.5.1.ebuild b/dev-python/irc/irc-8.5.1.ebuild
new file mode 100644
index 000000000000..bc26213877d0
--- /dev/null
+++ b/dev-python/irc/irc-8.5.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/irc-8.5.1.ebuild,v 1.1 2013/08/26 02:38:37 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="IRC client framework written in Python."
+HOMEPAGE="https://bitbucket.org/jaraco/irc http://pypi.python.org/pypi/irc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND="app-arch/unzip
+ app-text/dos2unix
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/hgtools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND="!>=dev-python/python-irclib-3.2.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Prevent setup from downloading hgtools package
+ dos2unix setup.py || die "Failed attempt of conversion by dos2unix"
+
+ # Don't rely on hgtools for version
+ sed -e "s/use_hg_version=True/version=\"${PV}\"/" -i setup.py || die
+ sed -e "/^tag_/d" -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test irc/tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( scripts/. )
+ distutils-r1_python_install_all
+}