summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-09 09:46:27 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-09 09:46:27 +0000
commitcd8f432ab7198cded4dc1b4d634bad5adf541840 (patch)
treee5f8a87ce52b06339157b237fb3d491879f0c761 /dev-python/irc
parentVersion bump and remove old. New ebuild uses autotools-utils. (diff)
downloadgentoo-2-cd8f432ab7198cded4dc1b4d634bad5adf541840.tar.gz
gentoo-2-cd8f432ab7198cded4dc1b4d634bad5adf541840.tar.bz2
gentoo-2-cd8f432ab7198cded4dc1b4d634bad5adf541840.zip
bump + test phase
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/irc')
-rw-r--r--dev-python/irc/ChangeLog10
-rw-r--r--dev-python/irc/files/irc-8-setup.py.patch11
-rw-r--r--dev-python/irc/irc-8.0.ebuild46
3 files changed, 65 insertions, 2 deletions
diff --git a/dev-python/irc/ChangeLog b/dev-python/irc/ChangeLog
index edeefd034217..1aaa14ddb72b 100644
--- a/dev-python/irc/ChangeLog
+++ b/dev-python/irc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/irc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/ChangeLog,v 1.4 2012/11/29 07:32:03 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/ChangeLog,v 1.5 2013/03/09 09:46:26 idella4 Exp $
+
+*irc-8.0 (09 Mar 2013)
+
+ 09 Mar 2013; Ian Delaney <idella4@gentoo.org> +files/irc-8-setup.py.patch,
+ +irc-8.0.ebuild:
+ bump + test phase
*irc-5.0.1 (29 Nov 2012)
diff --git a/dev-python/irc/files/irc-8-setup.py.patch b/dev-python/irc/files/irc-8-setup.py.patch
new file mode 100644
index 000000000000..caf46d48ad08
--- /dev/null
+++ b/dev-python/irc/files/irc-8-setup.py.patch
@@ -0,0 +1,11 @@
+diff -ur irc-8.0.orig/setup.py irc-8.0/setup.py
+--- irc-8.0.orig/setup.py 2013-01-12 22:14:36.000000000 +0800
++++ irc-8.0/setup.py 2013-03-09 16:53:15.012847123 +0800
+@@ -34,7 +34,6 @@
+ install_requires=[
+ ] + importlib_req + argparse_req,
+ setup_requires=[
+- 'hgtools',
+ 'pytest-runner',
+ ],
+ tests_require=[
diff --git a/dev-python/irc/irc-8.0.ebuild b/dev-python/irc/irc-8.0.ebuild
new file mode 100644
index 000000000000..709bf33c9da1
--- /dev/null
+++ b/dev-python/irc/irc-8.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/irc-8.0.ebuild,v 1.1 2013/03/09 09:46:26 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="IRC client framework written in Python."
+HOMEPAGE="https://bitbucket.org/jaraco/irc http://pypi.python.org/pypi/irc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND="app-arch/unzip
+ app-text/dos2unix
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+RDEPEND="!>=dev-python/python-irclib-3.2.2"
+
+src_prepare() {
+ # Prevent setup from downloading hgtools package
+ # Don't rely on hgtools for version, patch MUST be applied first
+ epatch "${FILESDIR}/${PN}-8-setup.py.patch"
+ dos2unix setup.py || die "Oops :("
+ sed -e "s/use_hg_version=True/version=\"${PV}\"/" \
+ -i setup.py || die
+ sed -e "/^tag_/d" -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ py.test || die
+}
+
+src_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ insinto "/usr/share/doc/${PF}/examples"
+ doins scripts/*
+ fi
+}