summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-06 08:51:53 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-06 08:51:53 +0000
commitef527ff8f338723c6610eb1bc08c910266e9d9b4 (patch)
tree9e39a678c62e40029df625ebda9400fa9e8f4fad /dev-python/irc
parentclean old impls, add py3.4 support (diff)
downloadgentoo-2-ef527ff8f338723c6610eb1bc08c910266e9d9b4.tar.gz
gentoo-2-ef527ff8f338723c6610eb1bc08c910266e9d9b4.tar.bz2
gentoo-2-ef527ff8f338723c6610eb1bc08c910266e9d9b4.zip
bump; minor re-write; deps upgraded, tidied, redundant patch and sed statements dropped
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/irc')
-rw-r--r--dev-python/irc/ChangeLog9
-rw-r--r--dev-python/irc/files/irc-8.5.1-setup_requires.patch22
-rw-r--r--dev-python/irc/irc-10.0.ebuild41
3 files changed, 60 insertions, 12 deletions
diff --git a/dev-python/irc/ChangeLog b/dev-python/irc/ChangeLog
index 09898313c431..54f34c42fbf9 100644
--- a/dev-python/irc/ChangeLog
+++ b/dev-python/irc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/irc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/ChangeLog,v 1.26 2014/08/10 21:12:14 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/ChangeLog,v 1.27 2014/11/06 08:51:53 idella4 Exp $
+
+*irc-10.0 (06 Nov 2014)
+
+ 06 Nov 2014; Ian Delaney <idella4@gentoo.org> +irc-10.0.ebuild,
+ files/irc-8.5.1-setup_requires.patch:
+ bump; minor re-write; deps upgraded, tidied, redundant patch and sed
+ statements dropped
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> irc-8.9.1.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/dev-python/irc/files/irc-8.5.1-setup_requires.patch b/dev-python/irc/files/irc-8.5.1-setup_requires.patch
index 732146c33741..f07e034ae035 100644
--- a/dev-python/irc/files/irc-8.5.1-setup_requires.patch
+++ b/dev-python/irc/files/irc-8.5.1-setup_requires.patch
@@ -1,13 +1,13 @@
--- a/setup.py
+++ b/setup.py
-@@ -34,10 +33,6 @@
- install_requires=[
- 'six',
- ] + importlib_req + argparse_req,
-- setup_requires=[
-- 'hgtools',
-- 'pytest-runner',
-- ],
- tests_require=[
- 'pytest',
- 'mock',
+@@ -35,10 +35,6 @@
+ install_requires=[
+ 'six',
+ ] + importlib_req + argparse_req,
+- setup_requires=[
+- 'hgtools',
+- 'pytest-runner',
+- ],
+ tests_require=[
+ 'pytest',
+ 'mock',
diff --git a/dev-python/irc/irc-10.0.ebuild b/dev-python/irc/irc-10.0.ebuild
new file mode 100644
index 000000000000..f13491ba1e55
--- /dev/null
+++ b/dev-python/irc/irc-10.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/irc-10.0.ebuild,v 1.1 2014/11/06 08:51:53 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="IRC client framework written in Python"
+HOMEPAGE="https://bitbucket.org/jaraco/irc http://pypi.python.org/pypi/irc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="
+ !>=dev-python/python-irclib-3.2.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jaraco-utils[${PYTHON_USEDEP}]"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/hgtools-5[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+
+# A doc folder is present however it has no makefile; will require a manual rst or epydoc build
+python_test() {
+ # https://bitbucket.org/jaraco/irc/issue/47/testchanneltest_has_user-fails-in-release
+ py.test irc/tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( scripts/. )
+ distutils-r1_python_install_all
+}