summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-05-10 22:40:51 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-05-10 22:40:51 +0000
commite5e7b9a8bcefcf36dd2a8d08c97ebab796aa19b6 (patch)
treef991d7425dfde70d2089b7d43f896ff196f1e55e /dev-python/jedi
parentFix creating libLLVM-3.4.so compatibility alias. (diff)
downloadgentoo-2-e5e7b9a8bcefcf36dd2a8d08c97ebab796aa19b6.tar.gz
gentoo-2-e5e7b9a8bcefcf36dd2a8d08c97ebab796aa19b6.tar.bz2
gentoo-2-e5e7b9a8bcefcf36dd2a8d08c97ebab796aa19b6.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'dev-python/jedi')
-rw-r--r--dev-python/jedi/ChangeLog9
-rw-r--r--dev-python/jedi/jedi-0.8.0.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-python/jedi/ChangeLog b/dev-python/jedi/ChangeLog
index c4df60cb73ec..810589c8a60d 100644
--- a/dev-python/jedi/ChangeLog
+++ b/dev-python/jedi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/jedi
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jedi/ChangeLog,v 1.6 2013/11/24 13:48:46 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jedi/ChangeLog,v 1.7 2014/05/10 22:40:51 hasufell Exp $
+
+*jedi-0.8.0 (10 May 2014)
+
+ 10 May 2014; Julian Ospald <hasufell@gentoo.org> +jedi-0.8.0.ebuild:
+ version bump
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> jedi-0.7.0.ebuild:
Stable for x86, wrt bug #491542
diff --git a/dev-python/jedi/jedi-0.8.0.ebuild b/dev-python/jedi/jedi-0.8.0.ebuild
new file mode 100644
index 000000000000..d60c6d81ee83
--- /dev/null
+++ b/dev-python/jedi/jedi-0.8.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jedi/jedi-0.8.0.ebuild,v 1.1 2014/05/10 22:40:51 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
+inherit distutils-r1
+
+MY_PV="${PV/_beta/b}-final0"
+
+DESCRIPTION="Awesome autocompletion library for python"
+HOMEPAGE="https://github.com/davidhalter/jedi"
+SRC_URI="mirror://pypi/j/jedi/jedi-${MY_PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="app-arch/xz-utils
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+python_test() {
+ PYTHONPATH="${PYTHONPATH%:}${PYTHONPATH+:}${S}/test" py.test test || die "Tests failed under ${EPYTHON}"
+}
+
+src_compile() {
+ if use doc ; then
+ emake -C docs html
+ fi
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ use doc && dohtml -r "${S}"/docs/_build/html/*
+ distutils-r1_python_install_all
+}