summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-03 06:42:42 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-03 06:42:42 +0000
commit220f405102653c21ad41835622a5a3c4108a1cca (patch)
treec1f656ec7d0a3efcc75cdcf22bd72fca54986a7f /dev-python/jsonpointer
parentAdd python3_4 support. (diff)
downloadgentoo-2-220f405102653c21ad41835622a5a3c4108a1cca.tar.gz
gentoo-2-220f405102653c21ad41835622a5a3c4108a1cca.tar.bz2
gentoo-2-220f405102653c21ad41835622a5a3c4108a1cca.zip
Version bump, run tests, update PYTHON_COMPAT, and add upstream info to metadata.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/jsonpointer')
-rw-r--r--dev-python/jsonpointer/ChangeLog9
-rw-r--r--dev-python/jsonpointer/jsonpointer-1.3.ebuild24
-rw-r--r--dev-python/jsonpointer/metadata.xml3
3 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/jsonpointer/ChangeLog b/dev-python/jsonpointer/ChangeLog
index 4548d15acc40..ff724a5c2db5 100644
--- a/dev-python/jsonpointer/ChangeLog
+++ b/dev-python/jsonpointer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/jsonpointer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpointer/ChangeLog,v 1.2 2014/03/19 18:19:31 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpointer/ChangeLog,v 1.3 2014/04/03 06:42:42 radhermit Exp $
+
+*jsonpointer-1.3 (03 Apr 2014)
+
+ 03 Apr 2014; Tim Harder <radhermit@gentoo.org> +jsonpointer-1.3.ebuild,
+ metadata.xml:
+ Version bump, run tests, update PYTHON_COMPAT, and add upstream info to
+ metadata.
19 Mar 2014; Sébastien Fabbro <bicatali@gentoo.org> jsonpointer-0.7.ebuild:
Keyword amd64-linux and x86-linux
diff --git a/dev-python/jsonpointer/jsonpointer-1.3.ebuild b/dev-python/jsonpointer/jsonpointer-1.3.ebuild
new file mode 100644
index 000000000000..c165be7828fe
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpointer/jsonpointer-1.3.ebuild,v 1.1 2014/04/03 06:42:42 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.python.org/pypi/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/jsonpointer/metadata.xml b/dev-python/jsonpointer/metadata.xml
index 6c29108ceb0e..ed0dce1050e0 100644
--- a/dev-python/jsonpointer/metadata.xml
+++ b/dev-python/jsonpointer/metadata.xml
@@ -10,5 +10,8 @@
Identify specific nodes in a JSON document (according to draft 08)
http://tools.ietf.org/html/draft-ietf-appsawg-json-pointer-08
</longdescription>
+ <upstream>
+ <remote-id type="pypi">jsonpointer</remote-id>
+ </upstream>
</pkgmetadata>