summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-08-22 00:01:12 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-08-22 00:01:12 +0000
commit30540fc037b5dc48675f8a7c7c2652758622ed26 (patch)
treecbb1fab9c00a0943ed9458d93e29440ae913ceff /dev-python/ldaptor
parentInitial Commit. Dependency for Bug #167164 (diff)
downloadgentoo-2-30540fc037b5dc48675f8a7c7c2652758622ed26.tar.gz
gentoo-2-30540fc037b5dc48675f8a7c7c2652758622ed26.tar.bz2
gentoo-2-30540fc037b5dc48675f8a7c7c2652758622ed26.zip
Version bump. Bug #167164
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/ldaptor')
-rw-r--r--dev-python/ldaptor/ChangeLog9
-rw-r--r--dev-python/ldaptor/files/ldaptor-0.0.43-usage-exception.patch13
-rw-r--r--dev-python/ldaptor/files/ldaptor-0.0.43-zope_interface.patch71
-rw-r--r--dev-python/ldaptor/ldaptor-0.0.43.ebuild85
4 files changed, 177 insertions, 1 deletions
diff --git a/dev-python/ldaptor/ChangeLog b/dev-python/ldaptor/ChangeLog
index 7f5bed8a7000..2e34521c899c 100644
--- a/dev-python/ldaptor/ChangeLog
+++ b/dev-python/ldaptor/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/ldaptor
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ldaptor/ChangeLog,v 1.21 2008/08/19 13:05:41 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ldaptor/ChangeLog,v 1.22 2008/08/22 00:01:12 neurogeek Exp $
+
+*ldaptor-0.0.43 (21 Aug 2008)
+
+ 21 Aug 2008; Jesus Rivero <neurogeek@gentoo.org>
+ +files/ldaptor-0.0.43-usage-exception.patch,
+ +files/ldaptor-0.0.43-zope_interface.patch, +ldaptor-0.0.43.ebuild:
+ Version bump. Bug #167164
19 Aug 2008; Ali Polatel <hawking@gentoo.org> ldaptor-0.0.42.ebuild:
Use python_get_sitedir, quoting, keyword ~amd64, set PYTHONPATH=. for
diff --git a/dev-python/ldaptor/files/ldaptor-0.0.43-usage-exception.patch b/dev-python/ldaptor/files/ldaptor-0.0.43-usage-exception.patch
new file mode 100644
index 000000000000..63e3d8f5459c
--- /dev/null
+++ b/dev-python/ldaptor/files/ldaptor-0.0.43-usage-exception.patch
@@ -0,0 +1,13 @@
+diff -uNtr ldaptor-0.0.43.orig/ldaptor/usage.py ldaptor-0.0.43/ldaptor/usage.py
+--- ldaptor-0.0.43.orig/ldaptor/usage.py 2008-08-20 12:38:44.000000000 -0430
++++ ldaptor-0.0.43/ldaptor/usage.py 2008-08-20 20:02:14.000000000 -0430
+@@ -2,6 +2,9 @@
+ from ldaptor.protocols import pureldap
+ from ldaptor.protocols.ldap import distinguishedname
+
++class UsageError(usage.UsageError):
++ pass
++
+ class Options(usage.Options):
+ optParameters = ()
+ def postOptions(self):
diff --git a/dev-python/ldaptor/files/ldaptor-0.0.43-zope_interface.patch b/dev-python/ldaptor/files/ldaptor-0.0.43-zope_interface.patch
new file mode 100644
index 000000000000..b9c8e78d5533
--- /dev/null
+++ b/dev-python/ldaptor/files/ldaptor-0.0.43-zope_interface.patch
@@ -0,0 +1,71 @@
+diff -uNtr ldaptor-0.0.43.orig/ldaptor/apps/webui/iwebui.py ldaptor-0.0.43/ldaptor/apps/webui/iwebui.py
+--- ldaptor-0.0.43.orig/ldaptor/apps/webui/iwebui.py 2008-08-20 12:38:44.000000000 -0430
++++ ldaptor-0.0.43/ldaptor/apps/webui/iwebui.py 2008-08-20 12:44:53.000000000 -0430
+@@ -1,4 +1,4 @@
+-from twisted.python import components
++from zope import interface
+
+-class ICurrentDN(components.Interface):
++class ICurrentDN(interface.Interface):
+ """Marker interface for current DN for Ldaptor-webui."""
+diff -uNtr ldaptor-0.0.43.orig/ldaptor/apps/webui/search.py ldaptor-0.0.43/ldaptor/apps/webui/search.py
+--- ldaptor-0.0.43.orig/ldaptor/apps/webui/search.py 2008-08-20 12:38:44.000000000 -0430
++++ ldaptor-0.0.43/ldaptor/apps/webui/search.py 2008-08-20 12:37:42.000000000 -0430
+@@ -1,6 +1,7 @@
+ from zope.interface import implements
+ from twisted.internet import defer
+-from twisted.python import components
++#from twisted.python import components
++from zope import interface
+ from webut.skin import iskin
+ from ldaptor.protocols.ldap import ldapclient, ldapsyntax
+ from ldaptor.protocols.ldap import distinguishedname, ldapconnector
+@@ -17,7 +18,7 @@
+ from nevow import rend, inevow, loaders, url, tags
+ from formless import annotate, webform, iformless, configurable
+
+-class IMove(components.Interface):
++class IMove(interface.Interface):
+ """Entries being moved in the tree."""
+ pass
+
+diff -uNtr ldaptor-0.0.43.orig/ldaptor/interfaces.py ldaptor-0.0.43/ldaptor/interfaces.py
+--- ldaptor-0.0.43.orig/ldaptor/interfaces.py 2008-08-20 12:38:44.000000000 -0430
++++ ldaptor-0.0.43/ldaptor/interfaces.py 2008-08-20 12:38:19.000000000 -0430
+@@ -1,6 +1,7 @@
+-from twisted.python import components
++#from twisted.python import interface
++from zope import interface
+
+-class ILDAPEntry(components.Interface):
++class ILDAPEntry(interface.Interface):
+ """
+
+ Pythonic API for LDAP object access and modification.
+@@ -126,7 +127,7 @@
+ incorrect.
+ """
+
+-class IEditableLDAPEntry(components.Interface):
++class IEditableLDAPEntry(interface.Interface):
+ """Interface definition for editable LDAP entries."""
+
+ def __setitem__(self, key, value):
+@@ -206,7 +207,7 @@
+
+ """
+
+-class IConnectedLDAPEntry(components.Interface):
++class IConnectedLDAPEntry(interface.Interface):
+ """Interface definition for LDAP entries that are part of a bigger whole."""
+
+ def namingContext(self):
+@@ -334,7 +335,7 @@
+
+ """
+
+-class ILDAPConfig(components.Interface):
++class ILDAPConfig(interface.Interface):
+ """Generic LDAP configuration retrieval."""
+
+ def getBaseDN(self):
diff --git a/dev-python/ldaptor/ldaptor-0.0.43.ebuild b/dev-python/ldaptor/ldaptor-0.0.43.ebuild
new file mode 100644
index 000000000000..d4b4b1bd9735
--- /dev/null
+++ b/dev-python/ldaptor/ldaptor-0.0.43.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ldaptor/ldaptor-0.0.43.ebuild,v 1.1 2008/08/22 00:01:12 neurogeek Exp $
+
+inherit distutils
+
+DESCRIPTION="set of LDAP utilities for use from the command line"
+HOMEPAGE="http://www.inoi.fi/open/trac/ldaptor"
+SRC_URI="mirror://debian/pool/main/l/ldaptor/${PN}_${PV}.orig.tar.gz
+ doc? ( mirror://gentoo/${PN}-0.0.42-dia-pictures.tar.gz )"
+
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="web doc samba"
+
+DEPEND=">=dev-python/twisted-2
+ dev-python/twisted-names
+ dev-python/twisted-mail
+ dev-python/pyparsing
+ web? (
+ dev-python/webut
+ >=dev-python/nevow-0.3
+ dev-python/twisted-web
+ )
+ doc? (
+ dev-python/epydoc
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ )
+ samba? ( dev-python/pycrypto )"
+
+DOCS="README TODO ldaptor.schema"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-zope_interface.patch"
+ epatch "${FILESDIR}/${P}-usage-exception.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ cp "${WORKDIR}/ldaptor-pictures/"*.dia.png doc/
+ cd doc
+ # skip the slides generation because it doesn't work
+ sed -e "/\$(SLIDES:%\.xml=%\/index\.html) /d" -i Makefile
+ # replace the docbook.xsl with something that exists
+ stylesheet='xsl-stylesheets'
+ sed -e "s#stylesheet/xsl/nwalsh#${stylesheet}#" -i Makefile
+ emake || die "make failed"
+ cd ..
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if ! use web; then
+ rm "${D}"/usr/bin/ldaptor-webui || die "couldn't rm ldaptor-webui"
+ rm -rf "${D}"/$(python_get_sitedir)/ldaptor/apps/webui || die "couldn't prune webui"
+ else
+ cp ldaptor/apps/webui/skin-default.html "${D}"/$(python_get_sitedir)/ldaptor/apps/webui \
+ || die "couldn't copy default skin"
+ fi
+
+ # install examples
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/api doc/ldap-intro doc/examples
+ if use web; then
+ doins -r doc/examples.webui
+ fi
+ fi
+}
+
+src_test() {
+ local trialopts
+ if ! has_version ">=dev-python/twisted-2.1"; then
+ trialopts=-R
+ fi
+ PYTHONPATH=. trial ${trialopts} ldaptor || die "test failed"
+}