summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-09 09:46:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-09 09:46:54 +0000
commit19d688e2da225eb2b7345ada53a6ee7fbaae29ac (patch)
tree39568c82edabe90374b25d830a3e53a36659b793 /dev-python/libcloud
parentBump (diff)
downloadgentoo-2-19d688e2da225eb2b7345ada53a6ee7fbaae29ac.tar.gz
gentoo-2-19d688e2da225eb2b7345ada53a6ee7fbaae29ac.tar.bz2
gentoo-2-19d688e2da225eb2b7345ada53a6ee7fbaae29ac.zip
Bump
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/libcloud')
-rw-r--r--dev-python/libcloud/ChangeLog7
-rw-r--r--dev-python/libcloud/libcloud-0.11.3.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/libcloud/ChangeLog b/dev-python/libcloud/ChangeLog
index 3837df0e48a7..55e515253e63 100644
--- a/dev-python/libcloud/ChangeLog
+++ b/dev-python/libcloud/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/libcloud
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/ChangeLog,v 1.5 2012/08/04 16:02:47 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/ChangeLog,v 1.6 2012/10/09 09:46:54 patrick Exp $
+
+*libcloud-0.11.3 (09 Oct 2012)
+
+ 09 Oct 2012; Patrick Lauer <patrick@gentoo.org> +libcloud-0.11.3.ebuild:
+ Bump
*libcloud-0.11.1 (04 Aug 2012)
diff --git a/dev-python/libcloud/libcloud-0.11.3.ebuild b/dev-python/libcloud/libcloud-0.11.3.ebuild
new file mode 100644
index 000000000000..6a4826b6ef20
--- /dev/null
+++ b/dev-python/libcloud/libcloud-0.11.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/libcloud-0.11.3.ebuild,v 1.1 2012/10/09 09:46:54 patrick Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.6 3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] *-jython"
+DISTUTILS_SRC_TEST="setup.py"
+PYTHON_TESTS_RESTRICTED_ABIS="3.*"
+PYTHON_USE_WITH="ssl"
+
+inherit distutils
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="http://libcloud.apache.org/index.html"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="test? ( dev-python/mock )"
+
+S="${WORKDIR}/apache-${P}"
+
+src_test() {
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+ distutils_src_test
+}
+
+src_install() {
+ distutils_src_install
+ if use examples ; then
+ docinto examples/
+ dodoc "${S}"/example_*.py || die
+ fi
+}