summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-08-04 16:02:47 +0000
committerMike Gilbert <floppym@gentoo.org>2012-08-04 16:02:47 +0000
commit6d3a1f869f64bfaa881a95c20b72c26c2c7b9333 (patch)
treeb24f89bb01da3e79a7bcf223e9fe82e2adf1fbf6 /dev-python/libcloud
parentVersion bump (diff)
downloadgentoo-2-6d3a1f869f64bfaa881a95c20b72c26c2c7b9333.tar.gz
gentoo-2-6d3a1f869f64bfaa881a95c20b72c26c2c7b9333.tar.bz2
gentoo-2-6d3a1f869f64bfaa881a95c20b72c26c2c7b9333.zip
Version bump for security bug 429834.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/libcloud')
-rw-r--r--dev-python/libcloud/ChangeLog9
-rw-r--r--dev-python/libcloud/libcloud-0.11.1.ebuild (renamed from dev-python/libcloud/libcloud-0.10.1.ebuild)4
-rw-r--r--dev-python/libcloud/libcloud-0.5.2.ebuild25
-rw-r--r--dev-python/libcloud/libcloud-0.7.1.ebuild41
-rw-r--r--dev-python/libcloud/libcloud-0.9.1.ebuild41
5 files changed, 10 insertions, 110 deletions
diff --git a/dev-python/libcloud/ChangeLog b/dev-python/libcloud/ChangeLog
index 8586b7108164..3837df0e48a7 100644
--- a/dev-python/libcloud/ChangeLog
+++ b/dev-python/libcloud/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/libcloud
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/ChangeLog,v 1.4 2012/06/28 06:36:52 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/ChangeLog,v 1.5 2012/08/04 16:02:47 floppym Exp $
+
+*libcloud-0.11.1 (04 Aug 2012)
+
+ 04 Aug 2012; Mike Gilbert <floppym@gentoo.org> +libcloud-0.11.1.ebuild,
+ -libcloud-0.10.1.ebuild, -libcloud-0.5.2.ebuild, -libcloud-0.7.1.ebuild,
+ -libcloud-0.9.1.ebuild:
+ Version bump for security bug 429834.
*libcloud-0.10.1 (28 Jun 2012)
diff --git a/dev-python/libcloud/libcloud-0.10.1.ebuild b/dev-python/libcloud/libcloud-0.11.1.ebuild
index 57c1c90fe1a9..96b5b3817d40 100644
--- a/dev-python/libcloud/libcloud-0.10.1.ebuild
+++ b/dev-python/libcloud/libcloud-0.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/libcloud-0.10.1.ebuild,v 1.1 2012/06/28 06:36:52 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/libcloud-0.11.1.ebuild,v 1.1 2012/08/04 16:02:47 floppym Exp $
EAPI="3"
@@ -28,7 +28,7 @@ DEPEND="test? ( dev-python/mock )"
S="${WORKDIR}/apache-${P}"
src_test() {
- cp test/secrets.py-dist test/secrets.py || die
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
distutils_src_test
}
diff --git a/dev-python/libcloud/libcloud-0.5.2.ebuild b/dev-python/libcloud/libcloud-0.5.2.ebuild
deleted file mode 100644
index 49e4c801a57e..000000000000
--- a/dev-python/libcloud/libcloud-0.5.2.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/libcloud-0.5.2.ebuild,v 1.1 2011/07/25 15:57:56 patrick Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="Unified Interface to the Cloud - python support libs"
-HOMEPAGE="http://libcloud.apache.org/index.html"
-SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND=""
-DEPEND=""
-
-S="${WORKDIR}/apache-${P}"
diff --git a/dev-python/libcloud/libcloud-0.7.1.ebuild b/dev-python/libcloud/libcloud-0.7.1.ebuild
deleted file mode 100644
index 0c071044a304..000000000000
--- a/dev-python/libcloud/libcloud-0.7.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/libcloud-0.7.1.ebuild,v 1.2 2011/12/30 18:17:03 mr_bones_ Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2:2.6 3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.[45] *-jython"
-DISTUTILS_SRC_TEST="setup.py"
-PYTHON_TESTS_RESTRICTED_ABIS="3.*"
-PYTHON_USE_WITH="ssl"
-
-inherit distutils
-
-DESCRIPTION="Unified Interface to the Cloud - python support libs"
-HOMEPAGE="http://libcloud.apache.org/index.html"
-SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND=""
-DEPEND=""
-
-S="${WORKDIR}/apache-${P}"
-
-src_test() {
- cp test/secrets.py-dist test/secrets.py || die
- distutils_src_test
-}
-
-src_install() {
- distutils_src_install
- if use examples ; then
- docinto examples/
- dodoc "${S}"/example_*.py || die
- fi
-}
diff --git a/dev-python/libcloud/libcloud-0.9.1.ebuild b/dev-python/libcloud/libcloud-0.9.1.ebuild
deleted file mode 100644
index b40198734193..000000000000
--- a/dev-python/libcloud/libcloud-0.9.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/libcloud-0.9.1.ebuild,v 1.2 2012/04/19 07:09:49 mr_bones_ Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2:2.6 3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.[45] *-jython"
-DISTUTILS_SRC_TEST="setup.py"
-PYTHON_TESTS_RESTRICTED_ABIS="3.*"
-PYTHON_USE_WITH="ssl"
-
-inherit distutils
-
-DESCRIPTION="Unified Interface to the Cloud - python support libs"
-HOMEPAGE="http://libcloud.apache.org/index.html"
-SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-RDEPEND=""
-DEPEND="test? ( dev-python/mock )"
-
-S="${WORKDIR}/apache-${P}"
-
-src_test() {
- cp test/secrets.py-dist test/secrets.py || die
- distutils_src_test
-}
-
-src_install() {
- distutils_src_install
- if use examples ; then
- docinto examples/
- dodoc "${S}"/example_*.py || die
- fi
-}