summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-26 17:29:03 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-26 17:29:03 +0000
commit28e46e40d0fd641904f615fee22ec8ce526fbdf2 (patch)
tree9a40f4c178ea54beca699c5e174381f33f879091 /dev-python/libgnome-python
parentConvert to gnome-python-common-r1. (diff)
downloadgentoo-2-28e46e40d0fd641904f615fee22ec8ce526fbdf2.tar.gz
gentoo-2-28e46e40d0fd641904f615fee22ec8ce526fbdf2.tar.bz2
gentoo-2-28e46e40d0fd641904f615fee22ec8ce526fbdf2.zip
Convert to gnome-python-common-r1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/libgnome-python')
-rw-r--r--dev-python/libgnome-python/ChangeLog11
-rw-r--r--dev-python/libgnome-python/libgnome-python-2.28.1-r1.ebuild29
2 files changed, 37 insertions, 3 deletions
diff --git a/dev-python/libgnome-python/ChangeLog b/dev-python/libgnome-python/ChangeLog
index 1bb09a79c544..f512d35436b9 100644
--- a/dev-python/libgnome-python/ChangeLog
+++ b/dev-python/libgnome-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/libgnome-python
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libgnome-python/ChangeLog,v 1.37 2011/12/18 02:45:10 tetromino Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libgnome-python/ChangeLog,v 1.38 2014/05/26 17:29:03 mgorny Exp $
+
+*libgnome-python-2.28.1-r1 (26 May 2014)
+
+ 26 May 2014; Michał Górny <mgorny@gentoo.org>
+ +libgnome-python-2.28.1-r1.ebuild:
+ Convert to gnome-python-common-r1.
18 Dec 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
libgnome-python-2.28.1.ebuild:
@@ -157,4 +163,3 @@
+libgnome-python-2.22.1.ebuild:
Initial import of gnome-python split ebuilds. This package installs
bindings for essential GNOME libraries.
-
diff --git a/dev-python/libgnome-python/libgnome-python-2.28.1-r1.ebuild b/dev-python/libgnome-python/libgnome-python-2.28.1-r1.ebuild
new file mode 100644
index 000000000000..74488e8d0e57
--- /dev/null
+++ b/dev-python/libgnome-python/libgnome-python-2.28.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libgnome-python/libgnome-python-2.28.1-r1.ebuild,v 1.1 2014/05/26 17:29:03 mgorny Exp $
+
+EAPI="5"
+
+GNOME_ORG_MODULE="gnome-python"
+G_PY_BINDINGS=( gnome gnomeui )
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome-python-common-r1
+
+DESCRIPTION="Python bindings for essential GNOME libraries"
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="examples"
+
+RDEPEND=">=gnome-base/libgnome-2.24.1
+ >=gnome-base/libgnomeui-2.24.0
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ >=dev-python/pyorbit-2.24.0[${PYTHON_USEDEP}]
+ >=dev-python/libbonobo-python-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/gnome-vfs-python-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/libgnomecanvas-python-${PV}[${PYTHON_USEDEP}]
+ !<dev-python/gnome-python-2.22.1"
+DEPEND="${RDEPEND}"
+
+EXAMPLES=( examples/. )