summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-09-13 11:37:37 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-09-13 11:37:37 +0000
commitd09587603747850db51e0adcecdc1afb688ba58e (patch)
tree30e7bde5e0ab73250dae5bda03b922527e911a60 /dev-python/libnatpmp
parentSync the live ebuild with latest changes. (diff)
downloadgentoo-2-d09587603747850db51e0adcecdc1afb688ba58e.tar.gz
gentoo-2-d09587603747850db51e0adcecdc1afb688ba58e.tar.bz2
gentoo-2-d09587603747850db51e0adcecdc1afb688ba58e.zip
Version bump
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-python/libnatpmp')
-rw-r--r--dev-python/libnatpmp/ChangeLog6
-rw-r--r--dev-python/libnatpmp/libnatpmp-20130911.ebuild28
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/libnatpmp/ChangeLog b/dev-python/libnatpmp/ChangeLog
index 8eb25086b1ea..da69e9ebed91 100644
--- a/dev-python/libnatpmp/ChangeLog
+++ b/dev-python/libnatpmp/ChangeLog
@@ -1,4 +1,10 @@
+*libnatpmp-20130911 (13 Sep 2013)
+
+ 13 Sep 2013; Anthony G. Basile <blueness@gentoo.org>
+ +libnatpmp-20130911.ebuild:
+ Version bump
+
05 Sep 2013; Michał Górny <mgorny@gentoo.org> libnatpmp-20120821-r1.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/dev-python/libnatpmp/libnatpmp-20130911.ebuild b/dev-python/libnatpmp/libnatpmp-20130911.ebuild
new file mode 100644
index 000000000000..d52fb54e08d4
--- /dev/null
+++ b/dev-python/libnatpmp/libnatpmp-20130911.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libnatpmp/libnatpmp-20130911.ebuild,v 1.1 2013/09/13 11:37:37 blueness Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for libnatpmp, an alternative protocol to UPnP IGD."
+HOMEPAGE="http://miniupnp.free.fr/libnatpmp.html"
+SRC_URI="http://miniupnp.free.fr/files/download.php?file=${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=net-libs/${P}"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ epatch "${FILESDIR}"/link-against-system-lib.patch
+
+ #These are installed by net-libs/libnatpmp
+ rm -f Changelog.txt README || die
+ distutils-r1_python_prepare_all
+}