summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-08 17:59:48 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-08 17:59:48 +0000
commit9ea7925d12d1b5c22a56c37f8d605efcf7bb168e (patch)
tree2fbb76be3c0d566e664ab8a1735eb24024d2606b /dev-python/librharris
parentVersion bump. Don't inherit unused eclasses. (diff)
downloadgentoo-2-9ea7925d12d1b5c22a56c37f8d605efcf7bb168e.tar.gz
gentoo-2-9ea7925d12d1b5c22a56c37f8d605efcf7bb168e.tar.bz2
gentoo-2-9ea7925d12d1b5c22a56c37f8d605efcf7bb168e.zip
Update EAPI. Fix dependencies. Set SUPPORT_PYTHON_ABIS. Use PyPI mirrors. Set PYTHON_MODNAME.
(Portage version: 2.2.0_alpha4_p14/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/librharris')
-rw-r--r--dev-python/librharris/ChangeLog9
-rw-r--r--dev-python/librharris/librharris-0.1.14.ebuild35
2 files changed, 28 insertions, 16 deletions
diff --git a/dev-python/librharris/ChangeLog b/dev-python/librharris/ChangeLog
index 5a4878c53005..96809a32acb9 100644
--- a/dev-python/librharris/ChangeLog
+++ b/dev-python/librharris/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/librharris
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/librharris/ChangeLog,v 1.1 2009/02/03 20:07:22 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/librharris/ChangeLog,v 1.2 2010/11/08 17:59:48 arfrever Exp $
+
+ 08 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ librharris-0.1.14.ebuild:
+ Update EAPI. Fix dependencies. Set SUPPORT_PYTHON_ABIS. Use PyPI mirrors.
+ Set PYTHON_MODNAME.
*librharris-0.1.14 (03 Feb 2009)
diff --git a/dev-python/librharris/librharris-0.1.14.ebuild b/dev-python/librharris/librharris-0.1.14.ebuild
index 9ecf0cba0e85..6da88e474cc8 100644
--- a/dev-python/librharris/librharris-0.1.14.ebuild
+++ b/dev-python/librharris/librharris-0.1.14.ebuild
@@ -1,23 +1,30 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/librharris/librharris-0.1.14.ebuild,v 1.1 2009/02/03 20:07:22 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/librharris/librharris-0.1.14.ebuild,v 1.2 2010/11/08 17:59:48 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
-SLOT="0"
+MY_PN="lib_rharris"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python Internet Programming Library"
+HOMEPAGE="http://pypi.python.org/pypi/lib_rharris"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-MY_P="${P/lib/lib_}"
-DESCRIPTION="A Python library for pulling, parsing \
-and pickling remote web page data and related net-aware tasks."
-HOMEPAGE="http://www.python.org/pypi/lib_rharris"
-SRC_URI="http://pypi.python.org/packages/source/l/${PN/lib/lib_}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="virtual/python"
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
-src_install() {
- distutils_src_install
-}
+DOCS="changelog"
+PYTHON_MODNAME="${MY_PN}"