summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-10-10 17:49:39 +0000
committerFabian Groffen <grobian@gentoo.org>2009-10-10 17:49:39 +0000
commit2b82072cb0b90ebd8b4c436d79588ea9be744b43 (patch)
tree9823c78eda5b01d894b19ba40b7a5dc0942f2b7f /dev-python/matplotlib
parentMerge from Prefix (diff)
downloadgentoo-2-2b82072cb0b90ebd8b4c436d79588ea9be744b43.tar.gz
gentoo-2-2b82072cb0b90ebd8b4c436d79588ea9be744b43.tar.bz2
gentoo-2-2b82072cb0b90ebd8b4c436d79588ea9be744b43.zip
Merge from Prefix
(Portage version: 2.2.00.14552-prefix/cvs/Darwin powerpc, RepoMan options: --force)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog7
-rw-r--r--dev-python/matplotlib/files/matplotlib-0.99.0-freebsd7+.patch14
-rw-r--r--dev-python/matplotlib/files/matplotlib-0.99.1.1-prefix.patch49
-rw-r--r--dev-python/matplotlib/matplotlib-0.99.1.1.ebuild20
4 files changed, 82 insertions, 8 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index 3828984f6e64..0185741ffbb1 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.72 2009/10/09 19:07:58 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.73 2009/10/10 17:49:39 grobian Exp $
+
+ 10 Oct 2009; Fabian Groffen <grobian@gentoo.org>
+ +files/matplotlib-0.99.0-freebsd7+.patch, matplotlib-0.99.1.1.ebuild,
+ +files/matplotlib-0.99.1.1-prefix.patch:
+ Merge from Prefix
09 Oct 2009; Sébastien Fabbro <bicatali@gentoo.org>
-matplotlib-0.99.0.ebuild, matplotlib-0.99.1.1.ebuild:
diff --git a/dev-python/matplotlib/files/matplotlib-0.99.0-freebsd7+.patch b/dev-python/matplotlib/files/matplotlib-0.99.0-freebsd7+.patch
new file mode 100644
index 000000000000..88c7db018ca2
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-0.99.0-freebsd7+.patch
@@ -0,0 +1,14 @@
+add support for FreeBSD 7 and 8
+http://bugs.gentoo.org/show_bug.cgi?id=282059
+
+--- setupext.py
++++ setupext.py
+@@ -54,6 +54,8 @@
+ 'freebsd4' : [],
+ 'freebsd5' : [],
+ 'freebsd6' : [],
++ 'freebsd7' : [],
++ 'freebsd8' : [],
+ 'sunos5' : [],
+ 'gnukfreebsd5' : [],
+ 'gnukfreebsd6' : [],
diff --git a/dev-python/matplotlib/files/matplotlib-0.99.1.1-prefix.patch b/dev-python/matplotlib/files/matplotlib-0.99.1.1-prefix.patch
new file mode 100644
index 000000000000..53d389850811
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-0.99.1.1-prefix.patch
@@ -0,0 +1,49 @@
+--- setupext.py
++++ setupext.py
+@@ -46,12 +46,11 @@
+ import subprocess
+
+ basedir = {
+- 'win32' : ['win32_static',],
+- 'linux2' : ['/usr/local', '/usr'],
+- 'linux' : ['/usr/local', '/usr',],
+- 'cygwin' : ['/usr/local', '/usr',],
+- '_darwin' : ['/sw/lib/freetype2', '/sw/lib/freetype219', '/usr/local',
+- '/usr', '/sw'],
++ 'win32' : [],
++ 'linux2' : [],
++ 'linux' : [],
++ 'cygwin' : [],
++ '_darwin' : [],
+ # it appears builds with darwin are broken because of all the
+ # different flags the deps can be compile with, so I am pushing
+ # people to :
+@@ -59,13 +58,13 @@
+
+ 'darwin' : [],
+
+- 'freebsd4' : ['/usr/local', '/usr'],
+- 'freebsd5' : ['/usr/local', '/usr'],
+- 'freebsd6' : ['/usr/local', '/usr'],
+- 'sunos5' : [os.getenv('MPLIB_BASE') or '/usr/local',],
+- 'gnukfreebsd5' : ['/usr/local', '/usr'],
+- 'gnukfreebsd6' : ['/usr/local', '/usr'],
+- 'aix5' : ['/usr/local'],
++ 'freebsd4' : [],
++ 'freebsd5' : [],
++ 'freebsd6' : [],
++ 'sunos5' : [],
++ 'gnukfreebsd5' : [],
++ 'gnukfreebsd6' : [],
++ 'aix5' : [],
+ }
+
+ import sys, os, stat
+@@ -328,6 +327,7 @@
+
+ module.include_dirs.extend(incdirs)
+ module.include_dirs.append('.')
++ module.include_dirs.append(os.path.join(sys.prefix, 'include'))
+ module.library_dirs.extend(libdirs)
+
+ def getoutput(s):
diff --git a/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild b/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild
index f919cd529f27..9ae48583ccb8 100644
--- a/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild,v 1.3 2009/10/09 19:07:58 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild,v 1.4 2009/10/10 17:49:39 grobian Exp $
WX_GTK_VER=2.8
EAPI=2
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
IUSE="cairo doc excel examples fltk gtk latex qt3 qt4 traits tk wxwidgets"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
LICENSE="PYTHON BSD"
CDEPEND=">=dev-python/numpy-1.1
@@ -78,6 +78,11 @@ src_prepare() {
# avoid to launch xv while building examples docs
epatch "${FILESDIR}"/${PN}-0.98.5.2-no-xv.patch
+ # removes hardcoded lib paths, should not break non-Prefix, more
+ # likely to fix it in case of multilib
+ epatch "${FILESDIR}"/${P}-prefix.patch
+ epatch "${FILESDIR}"/${PN}-0.99.0-freebsd7+.patch
+
# create setup.cfg (see setup.cfg.template for any changes)
cat > setup.cfg <<-EOF
[provide_packages]
@@ -113,8 +118,8 @@ src_prepare() {
|| die "sed setup.py for FHS failed"
sed -i \
- -e "s:path = get_data_path():path = '/etc/matplotlib':" \
- -e "s:os.path.dirname(__file__):'/usr/share/${PN}':g" \
+ -e "s:path = get_data_path():path = '${EPREFIX}/etc/matplotlib':" \
+ -e "s:os.path.dirname(__file__):'${EPREFIX}/usr/share/${PN}':g" \
lib/matplotlib/{__init__,config/cutils}.py \
|| die "sed init for FHS failed"
@@ -125,7 +130,7 @@ src_prepare() {
lib/matplotlib/mpl-data/fonts/ttf/{Vera*,cm*,*.TXT} \
|| die "removed internal copies failed"
python_version
- ln -s /usr/share/python${PYVER}/CXX . || die
+ ln -s "${EPREFIX}"/usr/share/python${PYVER}/CXX . || die
# remove pyparsing only when upstream pyparsing included matplotlib
# fixes. See bug #260025
@@ -159,12 +164,13 @@ src_test() {
}
src_install() {
+ [[ -z ${ED} ]] && local ED=${D}
distutils_src_install
# respect FHS
dodir /usr/share/${PN}
- mv "${D}"/usr/*/*/site-packages/${PN}/{mpl-data,backends/Matplotlib.nib} \
- "${D}"/usr/share/${PN} || die "failed renaming"
+ mv "${ED}"/usr/*/*/site-packages/${PN}/{mpl-data,backends/Matplotlib.nib} \
+ "${ED}"/usr/share/${PN} || die "failed renaming"
insinto /etc/matplotlib
doins matplotlibrc matplotlib.conf \
|| die "installing config files failed"