summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-05-30 12:44:32 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-05-30 12:44:32 +0000
commit8f57333e4f1f8c325fce52df2089696415789fc5 (patch)
tree18febac4c2b83ebe5e587123e1269d2bd78dac01 /dev-python/munkres
parentKeyword ~mips (diff)
downloadgentoo-2-8f57333e4f1f8c325fce52df2089696415789fc5.tar.gz
gentoo-2-8f57333e4f1f8c325fce52df2089696415789fc5.tar.bz2
gentoo-2-8f57333e4f1f8c325fce52df2089696415789fc5.zip
Enable tests, install documentation, drop empty (R)DEPEND
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/munkres')
-rw-r--r--dev-python/munkres/ChangeLog8
-rw-r--r--dev-python/munkres/munkres-1.0.5.4-r1.ebuild (renamed from dev-python/munkres/munkres-1.0.5.4.ebuild)16
2 files changed, 20 insertions, 4 deletions
diff --git a/dev-python/munkres/ChangeLog b/dev-python/munkres/ChangeLog
index 3bba0021c6af..9382f7403aa9 100644
--- a/dev-python/munkres/ChangeLog
+++ b/dev-python/munkres/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/munkres
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/munkres/ChangeLog,v 1.2 2012/05/28 23:22:37 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/munkres/ChangeLog,v 1.3 2012/05/30 12:44:32 xarthisius Exp $
+
+*munkres-1.0.5.4-r1 (30 May 2012)
+
+ 30 May 2012; Kacper Kowalik <xarthisius@gentoo.org>
+ +munkres-1.0.5.4-r1.ebuild, -munkres-1.0.5.4.ebuild:
+ Enable tests, install documentation, drop empty (R)DEPEND
28 May 2012; Jeff Horelick <jdhore@gentoo.org> munkres-1.0.5.4.ebuild:
Keyword ~x86.
diff --git a/dev-python/munkres/munkres-1.0.5.4.ebuild b/dev-python/munkres/munkres-1.0.5.4-r1.ebuild
index 0ef0c5dfcf99..d96f1f7193e4 100644
--- a/dev-python/munkres/munkres-1.0.5.4.ebuild
+++ b/dev-python/munkres/munkres-1.0.5.4-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/munkres/munkres-1.0.5.4.ebuild,v 1.2 2012/05/28 23:22:37 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/munkres/munkres-1.0.5.4-r1.ebuild,v 1.1 2012/05/30 12:44:32 xarthisius Exp $
EAPI=4
+
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
@@ -17,5 +18,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
+src_test() {
+ testing() {
+ "$(PYTHON)" ${PN}.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ dohtml -r html/
+}