summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-09 06:35:20 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-09 06:35:20 +0000
commitfe1ce94b7c05ce92d0c96ed1d47513ce2c262a0c (patch)
treef5a7d1ad10f24ce97a17327511eb57d157ecfcaf /dev-python/mwlib
parentMask sys-apps/kmscon for removal. (diff)
downloadgentoo-2-fe1ce94b7c05ce92d0c96ed1d47513ce2c262a0c.tar.gz
gentoo-2-fe1ce94b7c05ce92d0c96ed1d47513ce2c262a0c.tar.bz2
gentoo-2-fe1ce94b7c05ce92d0c96ed1d47513ce2c262a0c.zip
rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/mwlib')
-rw-r--r--dev-python/mwlib/ChangeLog6
-rw-r--r--dev-python/mwlib/mwlib-0.15.10.ebuild132
-rw-r--r--dev-python/mwlib/mwlib-0.15.12.ebuild130
-rw-r--r--dev-python/mwlib/mwlib-0.15.14.ebuild130
4 files changed, 5 insertions, 393 deletions
diff --git a/dev-python/mwlib/ChangeLog b/dev-python/mwlib/ChangeLog
index 28734088e6c2..0b927f3629bb 100644
--- a/dev-python/mwlib/ChangeLog
+++ b/dev-python/mwlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/mwlib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mwlib/ChangeLog,v 1.34 2014/10/13 01:23:15 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mwlib/ChangeLog,v 1.35 2014/12/09 06:35:20 idella4 Exp $
+
+ 09 Dec 2014; Ian Delaney <idella4@gentoo.org> -mwlib-0.15.10.ebuild,
+ -mwlib-0.15.12.ebuild, -mwlib-0.15.14.ebuild:
+ rm old
13 Oct 2014; Ian Delaney <idella4@gentoo.org> mwlib-0.15.10.ebuild,
mwlib-0.15.12.ebuild, mwlib-0.15.14.ebuild, mwlib-0.15.15.ebuild:
diff --git a/dev-python/mwlib/mwlib-0.15.10.ebuild b/dev-python/mwlib/mwlib-0.15.10.ebuild
deleted file mode 100644
index 6ea59886705d..000000000000
--- a/dev-python/mwlib/mwlib-0.15.10.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mwlib/mwlib-0.15.10.ebuild,v 1.2 2014/10/13 01:23:15 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1 user
-
-DESCRIPTION="Tools for parsing Mediawiki content to other formats"
-HOMEPAGE="http://code.pediapress.com/wiki/wiki http://pypi.python.org/pypi/mwlib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc server"
-
-RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]
- >=dev-python/odfpy-0.9[${PYTHON_USEDEP}]
- <dev-python/odfpy-0.10[${PYTHON_USEDEP}]
- >=dev-python/pyPdf-1.12[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-1.5.5
- <dev-python/pyparsing-1.6[${PYTHON_USEDEP}]
- >=dev-python/timelib-0.2[${PYTHON_USEDEP}]
- virtual/latex-base
- >=dev-python/simplejson-2.3[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- >=dev-python/bottle-0.10[${PYTHON_USEDEP}]
- >=dev-python/apipkg-1.2[${PYTHON_USEDEP}]
- >=dev-python/qserve-0.2.7[${PYTHON_USEDEP}]
- dev-python/roman[${PYTHON_USEDEP}]
- >=dev-python/py-1.4[${PYTHON_USEDEP}]
- dev-python/sqlite3dbm[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- server? ( app-admin/sudo )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- app-arch/unzip
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# TODO: requires ploticus to generate timelines
-
-DOCS=(changelog.rst)
-
-pkg_setup() {
- if use server ; then
- enewgroup mwlib
- enewuser mwlib -1 -1 -1 mwlib
- fi
-}
-
-python_prepare_all() {
- # mwlib.apipkg is actually used.
- sed -e 's/, "apipkg"//' -i setup.py || die
-
- # Execute odflint script.
- sed \
- -e "/def _get_odflint_module():/,/odflint = _get_odflint_module()/d" \
- -e "s/odflint.lint(path)/os.system('odflint %s' % path)/" \
- -i tests/test_odfwriter.py || die
-
- # Disable test which requires installed mw-zip script.
- rm -f tests/test_{nuwiki,redirect,zipwiki}.py || die
- # Disable render test that fails for no apparent reason
- rm -f tests/test_render.py || die
- # Disable nserve test that fails for an apparent reason
- # Bug 474874
- rm -f tests/test_nserve.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]] ; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-
- if use server ; then
- keepdir /var/log/mwlib
- keepdir /var/cache/mwlib
-
- fowners mwlib:mwlib /var/log/mwlib /var/cache/mwlib
- fperms 0750 /var/log/mwlib /var/cache/mwlib
-
- insinto /etc/logrotate.d
- for d in mw-qserve nserve ; do
- newins "${FILESDIR}/${d}.logrotate" "${d}"
- newinitd "${FILESDIR}/${d}.initd" "${d}"
- newconfd "${FILESDIR}/${d}.confd" "${d}"
- done
-
- newins "${FILESDIR}/nslave.logrotate" "nslave"
- newinitd "${FILESDIR}/nslave.initd-r1" "nslave"
- newconfd "${FILESDIR}/nslave.confd-r1" "nslave"
-
- newins "${FILESDIR}/postman.logrotate" "postman"
- newinitd "${FILESDIR}/postman.initd-r1" "postman"
- newconfd "${FILESDIR}/postman.confd" "postman"
-
- insinto /etc/cron.d
- newins "${FILESDIR}/mwlib-purge-cache.cron-r1" "mwlib-purge-cache"
- else
- rm "${D}"/usr/bin/{mw-qserve,nserve,nslave,postman}* || die "removing binaries failed"
- fi
-}
-
-pkg_postinst() {
- elog "Please enable required image formats for dev-python/pillow"
- if use server ; then
- elog "A cronjob to cleanup the cache files got installed to"
- elog " /etc/cron.d/mwlib-purge-cache"
- elog "Default parameters are to clean every 24h, adjust it to your needs."
- fi
-}
diff --git a/dev-python/mwlib/mwlib-0.15.12.ebuild b/dev-python/mwlib/mwlib-0.15.12.ebuild
deleted file mode 100644
index 5fda8f8093c1..000000000000
--- a/dev-python/mwlib/mwlib-0.15.12.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mwlib/mwlib-0.15.12.ebuild,v 1.2 2014/10/13 01:23:15 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1 user
-
-DESCRIPTION="Tools for parsing Mediawiki content to other formats"
-HOMEPAGE="http://code.pediapress.com/wiki/wiki http://pypi.python.org/pypi/mwlib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc server test"
-
-RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]
- >=dev-python/odfpy-0.9[${PYTHON_USEDEP}]
- <dev-python/odfpy-0.10[${PYTHON_USEDEP}]
- >=dev-python/pyPdf-1.12[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
- <dev-python/pyparsing-1.6[${PYTHON_USEDEP}]
- >=dev-python/timelib-0.2[${PYTHON_USEDEP}]
- virtual/latex-base
- >=dev-python/simplejson-2.3[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- >=dev-python/bottle-0.10[${PYTHON_USEDEP}]
- >=dev-python/apipkg-1.2[${PYTHON_USEDEP}]
- >=dev-python/qserve-0.2.7[${PYTHON_USEDEP}]
- dev-python/roman[${PYTHON_USEDEP}]
- >=dev-python/py-1.4[${PYTHON_USEDEP}]
- dev-python/sqlite3dbm[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- server? ( app-admin/sudo )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- app-arch/unzip
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( >=dev-python/wsgiintercept-0.6[${PYTHON_USEDEP}] )"
-
-# TODO: requires ploticus to generate timelines
-
-DOCS=(changelog.rst)
-
-pkg_setup() {
- if use server ; then
- enewgroup mwlib
- enewuser mwlib -1 -1 -1 mwlib
- fi
-}
-
-python_prepare_all() {
- # mwlib.apipkg is actually used.
- sed -e 's/, "apipkg"//' -i setup.py || die
-
- # Execute odflint script.
- sed \
- -e "/def _get_odflint_module():/,/odflint = _get_odflint_module()/d" \
- -e "s/odflint.lint(path)/os.system('odflint %s' % path)/" \
- -i tests/test_odfwriter.py || die
-
- # Disable test which requires installed mw-zip or mw-render script
- # which don't get generated in distutils_install_for_testing for some reason
- rm -f tests/test_{nuwiki,redirect,render,zipwiki}.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]] ; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- distutils_install_for_testing
- PATH="${TEST_DIR}/scripts:${PATH}" py.test || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-
- if use server ; then
- keepdir /var/log/mwlib
- keepdir /var/cache/mwlib
-
- fowners mwlib:mwlib /var/log/mwlib /var/cache/mwlib
- fperms 0750 /var/log/mwlib /var/cache/mwlib
-
- insinto /etc/logrotate.d
- for d in mw-qserve nserve ; do
- newins "${FILESDIR}/${d}.logrotate" "${d}"
- newinitd "${FILESDIR}/${d}.initd" "${d}"
- newconfd "${FILESDIR}/${d}.confd" "${d}"
- done
-
- newins "${FILESDIR}/nslave.logrotate" "nslave"
- newinitd "${FILESDIR}/nslave.initd-r1" "nslave"
- newconfd "${FILESDIR}/nslave.confd-r1" "nslave"
-
- newins "${FILESDIR}/postman.logrotate" "postman"
- newinitd "${FILESDIR}/postman.initd-r1" "postman"
- newconfd "${FILESDIR}/postman.confd" "postman"
-
- insinto /etc/cron.d
- newins "${FILESDIR}/mwlib-purge-cache.cron-r1" "mwlib-purge-cache"
- else
- rm "${D}"/usr/bin/{mw-qserve,nserve,nslave,postman}* || die "removing binaries failed"
- fi
-}
-
-pkg_postinst() {
- elog "Please enable required image formats for dev-python/pillow"
- if use server ; then
- elog "A cronjob to cleanup the cache files got installed to"
- elog " /etc/cron.d/mwlib-purge-cache"
- elog "Default parameters are to clean every 24h, adjust it to your needs."
- fi
-}
diff --git a/dev-python/mwlib/mwlib-0.15.14.ebuild b/dev-python/mwlib/mwlib-0.15.14.ebuild
deleted file mode 100644
index 337537cf6d49..000000000000
--- a/dev-python/mwlib/mwlib-0.15.14.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mwlib/mwlib-0.15.14.ebuild,v 1.2 2014/10/13 01:23:15 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1 user
-
-DESCRIPTION="Tools for parsing Mediawiki content to other formats"
-HOMEPAGE="http://code.pediapress.com/wiki/wiki http://pypi.python.org/pypi/mwlib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc server test"
-
-RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]
- >=dev-python/odfpy-0.9[${PYTHON_USEDEP}]
- <dev-python/odfpy-0.10[${PYTHON_USEDEP}]
- >=dev-python/pyPdf-1.12[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
- <dev-python/pyparsing-1.6[${PYTHON_USEDEP}]
- >=dev-python/timelib-0.2[${PYTHON_USEDEP}]
- virtual/latex-base
- >=dev-python/simplejson-2.3[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- >=dev-python/bottle-0.10[${PYTHON_USEDEP}]
- >=dev-python/apipkg-1.2[${PYTHON_USEDEP}]
- >=dev-python/qserve-0.2.7[${PYTHON_USEDEP}]
- dev-python/roman[${PYTHON_USEDEP}]
- >=dev-python/py-1.4[${PYTHON_USEDEP}]
- dev-python/sqlite3dbm[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- server? ( app-admin/sudo )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- app-arch/unzip
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( >=dev-python/wsgiintercept-0.6[${PYTHON_USEDEP}] )"
-
-# TODO: requires ploticus to generate timelines
-
-DOCS=(changelog.rst)
-
-pkg_setup() {
- if use server ; then
- enewgroup mwlib
- enewuser mwlib -1 -1 -1 mwlib
- fi
-}
-
-python_prepare_all() {
- # mwlib.apipkg is actually used.
- sed -e 's/, "apipkg"//' -i setup.py || die
-
- # Execute odflint script.
- sed \
- -e "/def _get_odflint_module():/,/odflint = _get_odflint_module()/d" \
- -e "s/odflint.lint(path)/os.system('odflint %s' % path)/" \
- -i tests/test_odfwriter.py || die
-
- # Disable test which requires installed mw-zip or mw-render script
- # which don't get generated in distutils_install_for_testing for some reason
- rm -f tests/test_{nuwiki,redirect,render,zipwiki}.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]] ; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- distutils_install_for_testing
- PATH="${TEST_DIR}/scripts:${PATH}" py.test || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-
- if use server ; then
- keepdir /var/log/mwlib
- keepdir /var/cache/mwlib
-
- fowners mwlib:mwlib /var/log/mwlib /var/cache/mwlib
- fperms 0750 /var/log/mwlib /var/cache/mwlib
-
- insinto /etc/logrotate.d
- for d in mw-qserve nserve ; do
- newins "${FILESDIR}/${d}.logrotate" "${d}"
- newinitd "${FILESDIR}/${d}.initd" "${d}"
- newconfd "${FILESDIR}/${d}.confd" "${d}"
- done
-
- newins "${FILESDIR}/nslave.logrotate" "nslave"
- newinitd "${FILESDIR}/nslave.initd-r1" "nslave"
- newconfd "${FILESDIR}/nslave.confd-r1" "nslave"
-
- newins "${FILESDIR}/postman.logrotate" "postman"
- newinitd "${FILESDIR}/postman.initd-r1" "postman"
- newconfd "${FILESDIR}/postman.confd" "postman"
-
- insinto /etc/cron.d
- newins "${FILESDIR}/mwlib-purge-cache.cron-r1" "mwlib-purge-cache"
- else
- rm "${D}"/usr/bin/{mw-qserve,nserve,nslave,postman}* || die "removing binaries failed"
- fi
-}
-
-pkg_postinst() {
- elog "Please enable required image formats for dev-python/pillow"
- if use server ; then
- elog "A cronjob to cleanup the cache files got installed to"
- elog " /etc/cron.d/mwlib-purge-cache"
- elog "Default parameters are to clean every 24h, adjust it to your needs."
- fi
-}