summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-03 08:42:19 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-03 08:42:19 +0000
commit1b4f3a659fc9db84971e91dd791919e5e0156fd6 (patch)
treece71728f28e91b48b2c93681871737a7f2ee0998 /dev-python/nose
parentVersion Bump (diff)
downloadgentoo-2-1b4f3a659fc9db84971e91dd791919e5e0156fd6.tar.gz
gentoo-2-1b4f3a659fc9db84971e91dd791919e5e0156fd6.tar.bz2
gentoo-2-1b4f3a659fc9db84971e91dd791919e5e0156fd6.zip
Version Bump; drop old
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/ChangeLog9
-rw-r--r--dev-python/nose/metadata.xml3
-rw-r--r--dev-python/nose/nose-1.1.2-r1.ebuild79
-rw-r--r--dev-python/nose/nose-1.2.1.ebuild88
-rw-r--r--dev-python/nose/nose-1.2.1_p2012.ebuild88
-rw-r--r--dev-python/nose/nose-1.3.0.ebuild87
-rw-r--r--dev-python/nose/nose-1.3.7.ebuild (renamed from dev-python/nose/nose-1.3.3.ebuild)32
7 files changed, 25 insertions, 361 deletions
diff --git a/dev-python/nose/ChangeLog b/dev-python/nose/ChangeLog
index 7df657b83dce..2d705bda1519 100644
--- a/dev-python/nose/ChangeLog
+++ b/dev-python/nose/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/nose
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.143 2015/04/08 08:04:54 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.144 2015/06/03 08:42:19 jlec Exp $
+
+*nose-1.3.7 (03 Jun 2015)
+
+ 03 Jun 2015; Justin Lecher <jlec@gentoo.org> +nose-1.3.7.ebuild,
+ -nose-1.1.2-r1.ebuild, -nose-1.2.1.ebuild, -nose-1.2.1_p2012.ebuild,
+ -nose-1.3.0.ebuild, -nose-1.3.3.ebuild, metadata.xml:
+ Version Bump; drop old
08 Apr 2015; Michał Górny <mgorny@gentoo.org> nose-1.1.2-r1.ebuild,
nose-1.2.1.ebuild, nose-1.2.1_p2012.ebuild, nose-1.3.0.ebuild,
diff --git a/dev-python/nose/metadata.xml b/dev-python/nose/metadata.xml
index 176d3dd70d58..fd0dd165b42a 100644
--- a/dev-python/nose/metadata.xml
+++ b/dev-python/nose/metadata.xml
@@ -2,9 +2,6 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>python</herd>
- <use>
- <flag name="coverage">Utilize <pkg>dev-python/coverage</pkg></flag>
- </use>
<upstream>
<remote-id type="pypi">nose</remote-id>
</upstream>
diff --git a/dev-python/nose/nose-1.1.2-r1.ebuild b/dev-python/nose/nose-1.1.2-r1.ebuild
deleted file mode 100644
index 86e12ca73235..000000000000
--- a/dev-python/nose/nose-1.1.2-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.1.2-r1.ebuild,v 1.20 2015/04/08 08:04:54 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-inherit distutils-r1 eutils
-
-DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
-HOMEPAGE="http://pypi.python.org/pypi/nose http://readthedocs.org/docs/nose/ https://bitbucket.org/jpellerin/nose"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="coverage doc examples test"
-
-RDEPEND="coverage? ( dev-python/coverage[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )
- test? ( dev-python/twisted-core )"
-
-DOCS=( AUTHORS )
-
-python_prepare_all() {
- # Tests need to be converted, and they don't respect BUILD_DIR.
- use test && DISTUTILS_IN_SOURCE_BUILD=1
-
- # Disable sphinx.ext.intersphinx, requires network
- epatch "${FILESDIR}/${PN}-0.11.0-disable_intersphinx.patch"
- # Disable tests requiring network connection.
- sed \
- -e "s/test_resolve/_&/g" \
- -e "s/test_raises_bad_return/_&/g" \
- -e "s/test_raises_twisted_error/_&/g" \
- -i unit_tests/test_twisted.py || die "sed failed"
- # Disable versioning of nosetests script to avoid collision with
- # versioning performed by the eclass.
- sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" \
- -i setup.py || die "sed2 failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-src_test() {
- # nosetests use heavy multiprocessing during the tests.
- # this shall make them less likely to kill your system or timeout.
- local DISTUTILS_NO_PARALLEL_BUILD=1
-
- distutils-r1_src_test
-}
-
-python_test() {
- local targets=( egg_info )
- [[ ${EPYTHON} == python3.* ]] && targets+=( build_tests )
-
- esetup.py ${targets[@]}
- "${PYTHON}" selftest.py || die "tests failed with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install --install-data "${EPREFIX}/usr/share"
-}
-
-python_install_all() {
- if use doc; then
- dohtml -r -A txt doc/.build/html/*
- fi
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/nose/nose-1.2.1.ebuild b/dev-python/nose/nose-1.2.1.ebuild
deleted file mode 100644
index 44768e90ff0f..000000000000
--- a/dev-python/nose/nose-1.2.1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.2.1.ebuild,v 1.9 2015/04/08 08:04:54 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-inherit distutils-r1 eutils
-
-DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
-HOMEPAGE="http://pypi.python.org/pypi/nose http://readthedocs.org/docs/nose/ https://bitbucket.org/jpellerin/nose"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )
- test? ( dev-python/twisted-core )"
-
-DOCS=( AUTHORS )
-
-python_prepare_all() {
- # Tests need to be converted, and they don't respect BUILD_DIR.
- use test && DISTUTILS_IN_SOURCE_BUILD=1
-
- # Disable sphinx.ext.intersphinx, requires network, rogue test
- epatch "${FILESDIR}/${PN}-0.11.0-disable_intersphinx.patch" \
- "${FILESDIR}"/${P}-skiptest.patch
-
- # Disable tests requiring network connection.
- sed \
- -e "s/test_resolve/_&/g" \
- -e "s/test_raises_bad_return/_&/g" \
- -e "s/test_raises_twisted_error/_&/g" \
- -i unit_tests/test_twisted.py || die "sed failed"
- # Disable versioning of nosetests script to avoid collision with
- # versioning performed by the eclass.
- sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" \
- -i setup.py || die "sed2 failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- local add_targets=()
-
- if use test; then
- add_targets+=( egg_info )
- [[ ${EPYTHON} == python3* ]] && add_targets+=( build_tests )
- fi
-
- distutils-r1_python_compile ${add_targets[@]}
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-src_test() {
- # nosetests use heavy multiprocessing during the tests.
- # this shall make them less likely to kill your system or timeout.
- local DISTUTILS_NO_PARALLEL_BUILD=1
-
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" selftest.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install --install-data "${EPREFIX}/usr/share"
-}
-
-python_install_all() {
- if use doc; then
- dohtml -r -A txt doc/.build/html/*
- fi
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/nose/nose-1.2.1_p2012.ebuild b/dev-python/nose/nose-1.2.1_p2012.ebuild
deleted file mode 100644
index 2feca12d11cf..000000000000
--- a/dev-python/nose/nose-1.2.1_p2012.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.2.1_p2012.ebuild,v 1.8 2015/04/08 08:04:54 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3} pypy )
-inherit distutils-r1 eutils vcs-snapshot
-
-DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
-HOMEPAGE="http://pypi.python.org/pypi/nose http://readthedocs.org/docs/nose/ https://github.com/nose-devs/nose"
-SRC_URI="https://github.com/nose-devs/${PN}/archive/e879960507d51a.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )
- test? ( dev-python/twisted-core )"
-
-DOCS=( AUTHORS )
-
-python_prepare_all() {
- # Tests need to be converted, and they don't respect BUILD_DIR.
- use test && DISTUTILS_IN_SOURCE_BUILD=1
-
- # Disable sphinx.ext.intersphinx, requires network, rogue test
- epatch "${FILESDIR}/${PN}-0.11.0-disable_intersphinx.patch" \
- "${FILESDIR}"/${P/_p2012/}-skiptest.patch
-
- # Disable tests requiring network connection.
- sed \
- -e "s/test_resolve/_&/g" \
- -e "s/test_raises_bad_return/_&/g" \
- -e "s/test_raises_twisted_error/_&/g" \
- -i unit_tests/test_twisted.py || die "sed failed"
- # Disable versioning of nosetests script to avoid collision with
- # versioning performed by the eclass.
- sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" \
- -i setup.py || die "sed2 failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- local add_targets=()
-
- if use test; then
- add_targets+=( egg_info )
- [[ ${EPYTHON} == python3* ]] && add_targets+=( build_tests )
- fi
-
- distutils-r1_python_compile ${add_targets[@]}
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-src_test() {
- # nosetests use heavy multiprocessing during the tests.
- # this shall make them less likely to kill your system or timeout.
- local DISTUTILS_NO_PARALLEL_BUILD=1
-
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" selftest.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install --install-data "${EPREFIX}/usr/share"
-}
-
-python_install_all() {
- if use doc; then
- dohtml -r -A txt doc/.build/html/*
- fi
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/nose/nose-1.3.0.ebuild b/dev-python/nose/nose-1.3.0.ebuild
deleted file mode 100644
index 81b9693d29f4..000000000000
--- a/dev-python/nose/nose-1.3.0.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.3.0.ebuild,v 1.21 2015/04/08 08:04:54 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3} pypy )
-inherit distutils-r1 eutils
-
-DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
-HOMEPAGE="http://pypi.python.org/pypi/nose http://readthedocs.org/docs/nose/ https://bitbucket.org/jpellerin/nose"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )
- test? ( dev-python/twisted-core
- dev-python/unittest2 )"
-
-DOCS=( AUTHORS )
-
-python_prepare_all() {
- # Tests need to be converted, and they don't respect BUILD_DIR.
- use test && DISTUTILS_IN_SOURCE_BUILD=1
-
- # Disable sphinx.ext.intersphinx, requires network, rogue test
- epatch "${FILESDIR}"/${PN}-1.2.1-skiptest.patch
-
- # Disable tests requiring network connection.
- sed \
- -e "s/test_resolve/_&/g" \
- -e "s/test_raises_bad_return/_&/g" \
- -e "s/test_raises_twisted_error/_&/g" \
- -i unit_tests/test_twisted.py || die "sed failed"
- # Disable versioning of nosetests script to avoid collision with
- # versioning performed by the eclass.
- sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" \
- -i setup.py || die "sed2 failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- local add_targets=()
-
- if use test; then
- add_targets+=( egg_info )
- [[ ${EPYTHON} == python3* ]] && add_targets+=( build_tests )
- fi
-
- distutils-r1_python_compile ${add_targets[@]}
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-src_test() {
- # nosetests use heavy multiprocessing during the tests.
- # this shall make them less likely to kill your system or timeout.
- local DISTUTILS_NO_PARALLEL_BUILD=1
-
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" selftest.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install --install-data "${EPREFIX}/usr/share"
-}
-
-python_install_all() {
- local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-
- if use doc; then
- dohtml -r -A txt doc/.build/html/.
- fi
-}
diff --git a/dev-python/nose/nose-1.3.3.ebuild b/dev-python/nose/nose-1.3.7.ebuild
index 7e76faeb0944..ee9812875961 100644
--- a/dev-python/nose/nose-1.3.3.ebuild
+++ b/dev-python/nose/nose-1.3.7.ebuild
@@ -1,14 +1,18 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.3.3.ebuild,v 1.3 2015/04/08 08:04:54 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.3.7.ebuild,v 1.1 2015/06/03 08:42:19 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-inherit distutils-r1 eutils
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
-HOMEPAGE="http://pypi.python.org/pypi/nose http://readthedocs.org/docs/nose/ https://bitbucket.org/jpellerin/nose"
+HOMEPAGE="
+ http://pypi.python.org/pypi/nose
+ http://readthedocs.org/docs/nose/
+ https://bitbucket.org/jpellerin/nose"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
@@ -16,17 +20,12 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc examples test"
-RDEPEND="dev-python/coverage[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/coverage[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )
- test? ( dev-python/twisted-core
- dev-python/unittest2 )"
-
-DOCS=( AUTHORS )
-#PATCHES=(
-# "${FILESDIR}"/${PN}-1.2.1-skiptest.patch
-# "${FILESDIR}"/${PN}-1.3.1-version.patch )
+ doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
+ test? ( $(python_gen_cond_dep 'dev-python/twisted-core[${PYTHON_USEDEP}]' python2_7) )"
python_prepare_all() {
# Tests need to be converted, and they don't respect BUILD_DIR.
@@ -43,6 +42,9 @@ python_prepare_all() {
sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" \
-i setup.py || die "sed2 failed"
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/conf.py || die
+
distutils-r1_python_prepare_all
}
@@ -70,7 +72,7 @@ src_test() {
}
python_test() {
- "${PYTHON}" selftest.py || die "Tests fail with ${EPYTHON}"
+ "${PYTHON}" selftest.py -v || die "Tests fail with ${EPYTHON}"
}
python_install() {
@@ -78,7 +80,7 @@ python_install() {
}
python_install_all() {
- local EXAMPLES=( examples/. )
+ use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
if use doc; then