summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-24 04:14:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-24 04:14:58 +0000
commit71652b127a4443f1fe94e999c03fce3aca3db0bd (patch)
tree8acda9311f6e757a9142a06f3bfd5911bbc66be4 /dev-python/nose
parentVersion bump for next alpha release, fixes bugs in 1.7 development (diff)
downloadgentoo-2-71652b127a4443f1fe94e999c03fce3aca3db0bd.tar.gz
gentoo-2-71652b127a4443f1fe94e999c03fce3aca3db0bd.tar.bz2
gentoo-2-71652b127a4443f1fe94e999c03fce3aca3db0bd.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/nose-0.10.4.ebuild45
-rw-r--r--dev-python/nose/nose-0.11.0.ebuild59
2 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/nose/nose-0.10.4.ebuild b/dev-python/nose/nose-0.10.4.ebuild
deleted file mode 100644
index 24f0746c1c51..000000000000
--- a/dev-python/nose/nose-0.10.4.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.10.4.ebuild,v 1.9 2009/04/06 18:16:45 armin76 Exp $
-
-inherit distutils eutils
-
-DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
-HOMEPAGE="http://somethingaboutorange.com/mrl/projects/nose/"
-SRC_URI="http://somethingaboutorange.com/mrl/projects/nose/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 s390 ~sh sparc x86 ~x86-fbsd"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/setuptools"
-DEPEND="${RDEPEND}
- test? ( dev-python/twisted )"
-
-src_unpack() {
- distutils_src_unpack
-
- # Disable tests that access the network
- epatch "${FILESDIR}/${PN}-0.10.0-tests-nonetwork.patch"
-}
-
-src_install() {
- DOCS="AUTHORS"
- distutils_src_install --install-data /usr/share
-
- use doc && dohtml doc/*
-
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-src_test() {
- # Create the missing empty directory, that's required for tests to pass
- if [[ ! -e "${S}"/functional_tests/support/empty ]]; then
- mkdir "${S}"/functional_tests/support/empty
- fi
- PYTHONPATH=. "${python}" setup.py test || die "test failed"
-}
diff --git a/dev-python/nose/nose-0.11.0.ebuild b/dev-python/nose/nose-0.11.0.ebuild
deleted file mode 100644
index 6e345b8fe255..000000000000
--- a/dev-python/nose/nose-0.11.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.11.0.ebuild,v 1.8 2009/08/09 16:42:49 armin76 Exp $
-
-EAPI="2"
-
-inherit distutils eutils
-
-DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
-HOMEPAGE="http://somethingaboutorange.com/mrl/projects/nose/"
-SRC_URI="http://somethingaboutorange.com/mrl/projects/nose/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/setuptools"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
- test? ( dev-python/twisted )"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable tests and doc features that access the network
- epatch \
- "${FILESDIR}/${PN}-0.10.0-tests-nonetwork.patch" \
- "${FILESDIR}/${P}-disable_intersphinx.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc ; then
- cd doc
- mkdir -p .build/html .build/doctrees
- sphinx-build . html || die "building docs failed"
- fi
-}
-
-src_install() {
- DOCS="AUTHORS"
- distutils_src_install --install-data /usr/share
-
- use doc && dohtml -r -A txt doc/html/*
-
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-src_test() {
- # Create the missing empty directory, that's required for tests to pass
- if [[ ! -e "${S}"/functional_tests/support/empty ]]; then
- mkdir "${S}"/functional_tests/support/empty
- fi
- PYTHONPATH=. "${python}" setup.py test || die "test failed"
-}