summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-22 08:30:33 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-22 08:30:33 +0000
commitb7cc2006dc13cf4c810dd9279d09ed4fe31d8ddb (patch)
tree01db2d8ab7da8ebf8e36e93cb0c35b3c71b17502 /dev-python/nose
parentRemove old versions, patches. (diff)
downloadgentoo-2-b7cc2006dc13cf4c810dd9279d09ed4fe31d8ddb.tar.gz
gentoo-2-b7cc2006dc13cf4c810dd9279d09ed4fe31d8ddb.tar.bz2
gentoo-2-b7cc2006dc13cf4c810dd9279d09ed4fe31d8ddb.zip
revbump; drop masked pypy2_0, patch sourced from upstream to fix version issue in py3
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/ChangeLog9
-rw-r--r--dev-python/nose/files/nose-1.3.1-version.patch16
-rw-r--r--dev-python/nose/nose-1.3.1-r1.ebuild90
3 files changed, 114 insertions, 1 deletions
diff --git a/dev-python/nose/ChangeLog b/dev-python/nose/ChangeLog
index 99032ae47c66..6055782656c4 100644
--- a/dev-python/nose/ChangeLog
+++ b/dev-python/nose/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/nose
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.125 2014/04/11 13:48:26 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.126 2014/04/22 08:30:33 idella4 Exp $
+
+*nose-1.3.1-r1 (22 Apr 2014)
+
+ 22 Apr 2014; Ian Delaney <idella4@gentoo.org> +files/nose-1.3.1-version.patch,
+ +nose-1.3.1-r1.ebuild, nose-1.3.1.ebuild:
+ revbump; drop masked pypy2_0, patch sourced from upstream to fix version issue
+ in py3
11 Apr 2014; Ian Delaney <idella4@gentoo.org>
+files/nose-1.3.1-pypy-test.patch, nose-1.3.1.ebuild, nose-9999.ebuild:
diff --git a/dev-python/nose/files/nose-1.3.1-version.patch b/dev-python/nose/files/nose-1.3.1-version.patch
new file mode 100644
index 000000000000..8f6edb5be2ef
--- /dev/null
+++ b/dev-python/nose/files/nose-1.3.1-version.patch
@@ -0,0 +1,16 @@
+https://github.com/nose-devs/nose/commit/43c35e49106916f51f676455888fe7a39d030113.diff
+diff --git a/nose/pyversion.py b/nose/pyversion.py
+index fba5ada..8b56614 100644
+--- a/nose/pyversion.py
++++ b/nose/pyversion.py
+@@ -89,7 +89,8 @@ def __init__(self, cls, func):
+ self.__dict__ = func.__dict__.copy()
+ self._func = func
+ self.__self__ = UnboundSelf(cls)
+- self.im_class = cls
++ if sys.version_info < (3, 0):
++ self.im_class = cls
+
+ def address(self):
+ cls = self.__self__.cls
+
diff --git a/dev-python/nose/nose-1.3.1-r1.ebuild b/dev-python/nose/nose-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..9cf4be26eb7b
--- /dev/null
+++ b/dev-python/nose/nose-1.3.1-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.3.1-r1.ebuild,v 1.1 2014/04/22 08:30:33 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy )
+inherit distutils-r1 eutils
+
+DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
+HOMEPAGE="http://pypi.python.org/pypi/nose http://readthedocs.org/docs/nose/ https://bitbucket.org/jpellerin/nose"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.6 )
+ test? ( dev-python/twisted-core
+ dev-python/unittest2 )"
+
+DOCS=( AUTHORS )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.1-skiptest.patch
+ "${FILESDIR}"/${PN}-1.3.1-python3.4.patch
+ "${FILESDIR}"/${P}-doctest.patch
+ "${FILESDIR}"/${P}-pypy-test.patch
+ "${FILESDIR}"/${P}-version.patch )
+
+python_prepare_all() {
+ # Tests need to be converted, and they don't respect BUILD_DIR.
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+
+ # Disable tests requiring network connection.
+ sed \
+ -e "s/test_resolve/_&/g" \
+ -e "s/test_raises_bad_return/_&/g" \
+ -e "s/test_raises_twisted_error/_&/g" \
+ -i unit_tests/test_twisted.py || die "sed failed"
+ # Disable versioning of nosetests script to avoid collision with
+ # versioning performed by the eclass.
+ sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" \
+ -i setup.py || die "sed2 failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local add_targets=()
+
+ if use test; then
+ add_targets+=( egg_info )
+ python_is_python3 && add_targets+=( build_tests )
+ fi
+
+ distutils-r1_python_compile ${add_targets[@]}
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+src_test() {
+ # nosetests use heavy multiprocessing during the tests.
+ # this shall make them less likely to kill your system or timeout.
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ "${PYTHON}" selftest.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install --install-data "${EPREFIX}/usr/share"
+}
+
+python_install_all() {
+ local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dohtml -r -A txt doc/.build/html/.
+ fi
+}