summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-01-31 16:38:56 +0000
committerAli Polatel <hawking@gentoo.org>2008-01-31 16:38:56 +0000
commiteb24c11a3c2af450c51a4b56e2eb5c8d83a2f325 (patch)
tree2259c0c916a5c59f17c8249f9dfce8c0a78f199c /dev-python/nose
parentStable on ppc wrt bug 207841 (diff)
downloadgentoo-2-eb24c11a3c2af450c51a4b56e2eb5c8d83a2f325.tar.gz
gentoo-2-eb24c11a3c2af450c51a4b56e2eb5c8d83a2f325.tar.bz2
gentoo-2-eb24c11a3c2af450c51a4b56e2eb5c8d83a2f325.zip
Version bump.
(Portage version: 2.1.4)
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/ChangeLog9
-rw-r--r--dev-python/nose/nose-0.10.1.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/nose/ChangeLog b/dev-python/nose/ChangeLog
index f91d09bf5277..99020e4a4755 100644
--- a/dev-python/nose/ChangeLog
+++ b/dev-python/nose/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/nose
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.9 2007/10/14 11:53:59 hawking Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.10 2008/01/31 16:38:56 hawking Exp $
+
+*nose-0.10.1 (31 Jan 2008)
+
+ 31 Jan 2008; Ali Polatel <hawking@gentoo.org> +nose-0.10.1.ebuild:
+ Version bump.
*nose-0.10.0 (14 Oct 2007)
diff --git a/dev-python/nose/nose-0.10.1.ebuild b/dev-python/nose/nose-0.10.1.ebuild
new file mode 100644
index 000000000000..08a933ff7fb2
--- /dev/null
+++ b/dev-python/nose/nose-0.10.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.10.1.ebuild,v 1.1 2008/01/31 16:38:56 hawking Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
+HOMEPAGE="http://somethingaboutorange.com/mrl/projects/nose/"
+SRC_URI="http://somethingaboutorange.com/mrl/projects/nose/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/setuptools"
+DEPEND="${RDEPEND}
+ test? ( dev-python/twisted )"
+
+src_unpack() {
+ distutils_src_unpack
+
+ # Disable tests that access the network
+ epatch "${FILESDIR}/${PN}-0.10.0-tests-nonetwork.patch"
+}
+
+src_install() {
+ DOCS="AUTHORS"
+ distutils_src_install --install-data /usr/share
+
+ use doc && dohtml doc/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ PYTHONPATH=. "${python}" setup.py test || die "test failed"
+}