summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-16 18:38:04 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-16 18:38:04 +0000
commit7af71056a48e14e762238b8fc365e8daef9254ef (patch)
tree97360050cf822f666d2023027c69e1fac7277038 /dev-python/numpy/numpy-1.6.1.ebuild
parentAdd enhanced DEP support in fortran-2.eclass to easy the usage. Only inherit ... (diff)
downloadgentoo-2-7af71056a48e14e762238b8fc365e8daef9254ef.tar.gz
gentoo-2-7af71056a48e14e762238b8fc365e8daef9254ef.tar.bz2
gentoo-2-7af71056a48e14e762238b8fc365e8daef9254ef.zip
dev-python/numpy: Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the updated fortran-2.eclass
(Portage version: 2.2.0_alpha138/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-python/numpy/numpy-1.6.1.ebuild')
-rw-r--r--dev-python/numpy/numpy-1.6.1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/numpy/numpy-1.6.1.ebuild b/dev-python/numpy/numpy-1.6.1.ebuild
index 2c8d4636de66..e9edaab7c80f 100644
--- a/dev-python/numpy/numpy-1.6.1.ebuild
+++ b/dev-python/numpy/numpy-1.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.6.1.ebuild,v 1.6 2012/10/14 18:56:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.6.1.ebuild,v 1.7 2012/10/16 18:38:04 jlec Exp $
EAPI=3
@@ -30,7 +30,7 @@ IUSE="doc lapack test"
RDEPEND="
dev-python/setuptools
- lapack? ( virtual/cblas virtual/lapack virtual/fortran )"
+ lapack? ( virtual/cblas virtual/lapack )"
DEPEND="${RDEPEND}
doc? ( app-arch/unzip )
lapack? ( virtual/pkgconfig )
@@ -44,7 +44,7 @@ PYTHON_NONVERSIONED_EXECUTABLES=("/usr/bin/f2py[[:digit:]]+\.[[:digit:]]+")
DOCS="COMPATIBILITY DEV_README.txt THANKS.txt"
pkg_setup() {
- use lapack && fortran-2_pkg_setup
+ fortran-2_pkg_setup
python_pkg_setup
# See progress in http://projects.scipy.org/scipy/numpy/ticket/573