summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-22 11:20:40 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-22 11:20:40 +0000
commit4bd1257035216896a46988b73a6166f8b8e992ae (patch)
tree2d6dcf9afe899f18a20b98c2a683ba3f52f2f754 /dev-python/numpy
parentFix compat with latest gstreamermm, also fixing bug #501862 by Mark Purtill, ... (diff)
downloadgentoo-2-4bd1257035216896a46988b73a6166f8b8e992ae.tar.gz
gentoo-2-4bd1257035216896a46988b73a6166f8b8e992ae.tar.bz2
gentoo-2-4bd1257035216896a46988b73a6166f8b8e992ae.zip
dev-python/numpy: Drop vulnerable versions, #500484
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog6
-rw-r--r--dev-python/numpy/metadata.xml12
-rw-r--r--dev-python/numpy/numpy-1.8.0.ebuild144
3 files changed, 11 insertions, 151 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index 0d17cbca30d3..62bacf685e86 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/numpy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.229 2014/02/17 21:07:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.230 2014/02/22 11:20:40 jlec Exp $
+
+ 22 Feb 2014; Justin Lecher <jlec@gentoo.org> -numpy-1.8.0.ebuild,
+ metadata.xml:
+ Drop vulnerable versions, #500484
17 Feb 2014; Agostino Sarubbo <ago@gentoo.org> numpy-1.8.0-r1.ebuild:
Stable for arm, wrt bug #500484
diff --git a/dev-python/numpy/metadata.xml b/dev-python/numpy/metadata.xml
index bb330b7fd39b..0bfafa1af2f6 100644
--- a/dev-python/numpy/metadata.xml
+++ b/dev-python/numpy/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<herd>python</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <herd>python</herd>
+ <longdescription lang="en">
NumPy is a general-purpose array-processing Python package designed to
efficiently manipulate large multi-dimensional arrays of arbitrary
records without sacrificing too much speed for small multi-dimensional
@@ -11,7 +11,7 @@
basic linear algebra and random number generation.
It is the successor of Numeric and numarray.
</longdescription>
-<upstream>
- <remote-id type="pypi">numpy</remote-id>
-</upstream>
+ <upstream>
+ <remote-id type="pypi">numpy</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/numpy/numpy-1.8.0.ebuild b/dev-python/numpy/numpy-1.8.0.ebuild
deleted file mode 100644
index 6f5e4edafc81..000000000000
--- a/dev-python/numpy/numpy-1.8.0.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.8.0.ebuild,v 1.4 2014/01/18 12:16:02 vapier Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-FORTRAN_NEEDED=lapack
-
-inherit distutils-r1 eutils flag-o-matic fortran-2 multilib toolchain-funcs versionator
-
-DOC_PV="${PV}"
-
-DESCRIPTION="Fast array and numerical python library"
-HOMEPAGE="http://numpy.scipy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${P}/${PN}-html-${DOC_PV}.zip
- http://docs.scipy.org/doc/${P}/${PN}-ref-${DOC_PV}.pdf
- http://docs.scipy.org/doc/${P}/${PN}-user-${DOC_PV}.pdf
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc lapack test"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- lapack? ( virtual/cblas virtual/lapack )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )
- lapack? ( virtual/pkgconfig )
- test? ( >=dev-python/nose-0.10[${PYTHON_USEDEP}] )"
-
-# Uses distutils.command.config.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${PN}-html-${DOC_PV}.zip -d html || die
- fi
-}
-
-pc_incdir() {
- $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//'
-}
-
-pc_libdir() {
- $(tc-getPKG_CONFIG) --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//'
-}
-
-pc_libs() {
- $(tc-getPKG_CONFIG) --libs-only-l $@ | \
- sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
- | sort | uniq | tr '\n' ','
-}
-
-python_prepare_all() {
- epatch "${FILESDIR}"/${PN}-1.8.0-no-hardcode-blas.patch
-
- if use lapack; then
- append-ldflags "$($(tc-getPKG_CONFIG) --libs-only-other cblas lapack)"
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- # make sure _dotblas.so gets built
- sed -i -e '/NO_ATLAS_INFO/,+1d' numpy/core/setup.py || die
- cat >> site.cfg <<-EOF
- [blas]
- include_dirs = $(pc_incdir cblas)
- library_dirs = $(pc_libdir cblas blas):${libdir}
- blas_libs = $(pc_libs cblas blas)
- [lapack]
- library_dirs = $(pc_libdir lapack):${libdir}
- lapack_libs = $(pc_libs lapack)
- EOF
- else
- export {ATLAS,PTATLAS,BLAS,LAPACK,MKL}=None
- fi
-
- export CC="$(tc-getCC) ${CFLAGS}"
-
- append-flags -fno-strict-aliasing
-
- # See progress in http://projects.scipy.org/scipy/numpy/ticket/573
- # with the subtle difference that we don't want to break Darwin where
- # -shared is not a valid linker argument
- if [[ ${CHOST} != *-darwin* ]]; then
- append-ldflags -shared
- fi
-
- # only one fortran to link with:
- # linking with cblas and lapack library will force
- # autodetecting and linking to all available fortran compilers
- if use lapack; then
- append-fflags -fPIC
- NUMPY_FCONFIG="config_fc --noopt --noarch"
- # workaround bug 335908
- [[ $(tc-getFC) == *gfortran* ]] && NUMPY_FCONFIG+=" --fcompiler=gnu95"
- fi
-
- # don't version f2py, we will handle it.
- sed -i -e '/f2py_exe/s:+os\.path.*$::' numpy/f2py/setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile ${NUMPY_FCONFIG}
-}
-
-python_test() {
- distutils_install_for_testing ${NUMPY_FCONFIG}
-
- cd "${TMPDIR}" || die
- ${EPYTHON} -c "
-import numpy, sys
-r = numpy.test(verbose=3)
-sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install ${NUMPY_FCONFIG}
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- dodoc COMPATIBILITY DEV_README.txt THANKS.txt
-
- docinto f2py
- dodoc numpy/f2py/docs/*.txt
- doman numpy/f2py/f2py.1
-
- if use doc; then
- dohtml -r "${WORKDIR}"/html/*
- insinto /usr/share/doc/${PF}
- doins "${DISTDIR}"/${PN}-{user,ref}-${DOC_PV}.pdf
- fi
-}