summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-01-14 17:50:18 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-01-14 17:50:18 +0000
commit734d14e69addaa853e429834a1d09f6e83e7d46b (patch)
treeaaf8660f3ab8116ccc04721e2c9bd7031e2fde3a /dev-python/numpy
parentVersion bump (diff)
downloadgentoo-2-734d14e69addaa853e429834a1d09f6e83e7d46b.tar.gz
gentoo-2-734d14e69addaa853e429834a1d09f6e83e7d46b.tar.bz2
gentoo-2-734d14e69addaa853e429834a1d09f6e83e7d46b.zip
Fixes to pkg-config with lapack when atlas is selected
(Portage version: 2.2_rc20/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog8
-rw-r--r--dev-python/numpy/numpy-1.2.0.ebuild146
-rw-r--r--dev-python/numpy/numpy-1.2.1.ebuild14
3 files changed, 13 insertions, 155 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index 17afb1b39dcb..086266fd6933 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/numpy
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.68 2008/11/06 00:04:43 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.69 2009/01/14 17:50:18 bicatali Exp $
+
+ 12 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org> -numpy-1.2.0.ebuild,
+ numpy-1.2.1.ebuild:
+ Fixes to pkg-config with lapack when atlas is selected
*numpy-1.2.1 (06 Nov 2008)
diff --git a/dev-python/numpy/numpy-1.2.0.ebuild b/dev-python/numpy/numpy-1.2.0.ebuild
deleted file mode 100644
index 9ae4b97ce98e..000000000000
--- a/dev-python/numpy/numpy-1.2.0.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.2.0.ebuild,v 1.5 2008/12/07 19:11:59 vapier Exp $
-
-NEED_PYTHON=2.4
-
-inherit distutils eutils flag-o-matic fortran
-
-DESCRIPTION="Fast array and numerical python library"
-SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
-HOMEPAGE="http://numeric.scipy.org/"
-
-RDEPEND="!dev-python/f2py
- lapack? ( virtual/cblas virtual/lapack )"
-
-DEPEND="${RDEPEND}
- test? ( >=dev-python/nose-0.10 )
- lapack? ( dev-util/pkgconfig )"
-
-IUSE="lapack test"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~s390 ~sparc ~x86"
-LICENSE="BSD"
-
-# whatever LDFLAGS set will break linking
-# see progress in http://projects.scipy.org/scipy/numpy/ticket/573
-if [ -n "${LDFLAGS}" ]; then
- append-ldflags -shared
-else
- LDFLAGS="-shared"
-fi
-
-pkg_setup() {
- # only one fortran to link with:
- # linking with cblas and lapack library will force
- # autodetecting and linking to all available fortran compilers
- use lapack || return
- FORTRAN="gfortran g77 ifc"
- fortran_pkg_setup
- local fc=
- case ${FORTRANC} in
- gfortran) fc=gnu95 ;;
- g77) fc=gnu ;;
- ifc|ifort)
- if use ia64; then
- fc=intele
- elif use amd64; then
- fc=intelem
- else
- fc=intel
- fi
- ;;
- *) eerror "Unknown fortran compiler: ${FORTRANC}"
- die "numpy_fortran_setup failed" ;;
- esac
-
- # when fortran flags are set, pic is removed.
- use amd64 && FFLAGS="${FFLAGS} -fPIC"
- export NUMPY_FCONFIG="config_fc --fcompiler=${fc} --noopt --noarch"
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Fix some paths and docs in f2py
- epatch "${FILESDIR}"/${PN}-1.1.0-f2py.patch
-
- # Gentoo patch for ATLAS library names
- sed -i \
- -e "s:'f77blas':'blas':g" \
- -e "s:'ptf77blas':'blas':g" \
- -e "s:'ptcblas':'cblas':g" \
- -e "s:'lapack_atlas':'lapack':g" \
- numpy/distutils/system_info.py \
- || die "sed system_info.py failed"
-
- if use lapack; then
- append-ldflags "$(pkg-config --libs-only-other cblas lapack)"
- sed -i -e '/NO_ATLAS_INFO/,+1d' numpy/core/setup.py || die
- cat >> site.cfg <<-EOF
- [atlas]
- include_dirs = $(pkg-config --cflags-only-I \
- cblas lapack | sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $(pkg-config --libs-only-L \
- cblas lapack | sed -e \
- 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):/usr/$(get_libdir)
- atlas_libs = $(pkg-config --libs-only-l \
- cblas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- lapack_libs = $(pkg-config --libs-only-l \
- lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- [blas_opt]
- include_dirs = $(pkg-config --cflags-only-I \
- cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $(pkg-config --libs-only-L \
- cblas | sed -e 's/^-L//' -e 's/ -L/:/g' \
- -e 's/ //g'):/usr/$(get_libdir)
- libraries = $(pkg-config --libs-only-l \
- cblas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- [lapack_opt]
- library_dirs = $(pkg-config --libs-only-L \
- lapack | sed -e 's/^-L//' -e 's/ -L/:/g' \
- -e 's/ //g'):/usr/$(get_libdir)
- libraries = $(pkg-config --libs-only-l \
- lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- EOF
- else
- export {ATLAS,PTATLAS,BLAS,LAPACK,MKL}=None
- fi
-}
-
-src_compile() {
- # when fortran flags are set, pic is removed but unfortunately needed
- distutils_src_compile ${NUMPY_FCONFIG}
-}
-
-src_test() {
- "${python}" setup.py ${NUMPY_FCONFIG} install \
- --home="${S}"/test \
- --no-compile \
- || die "install test failed"
- pushd "${S}"/test/lib*
- PYTHONPATH=python "${python}" -c "import numpy; numpy.test()" 2>&1 | tee test.log
- grep -q '^ERROR' test.log && die "test failed"
- popd
- rm -rf test
-}
-
-src_install() {
- distutils_src_install ${NUMPY_FCONFIG}
- dodoc THANKS.txt DEV_README.txt COMPATIBILITY
- rm -f "${D}"/usr/lib/python*/site-packages/numpy/*.txt
- docinto f2py
- dodoc numpy/f2py/docs/*.txt || die "dodoc f2py failed"
- doman numpy/f2py/f2py.1 || die "doman failed"
-}
-
-pkg_postinst() {
- if ! built_with_use sys-devel/gcc fortran &&
- ! has_version dev-lang/ifc
- then
- ewarn "To use numpy's f2py you need a fortran compiler."
- ewarn "You can either set USE=fortran flag and re-install gcc,"
- ewarn "or install dev-lang/ifc"
- fi
-}
diff --git a/dev-python/numpy/numpy-1.2.1.ebuild b/dev-python/numpy/numpy-1.2.1.ebuild
index be8c9a61cba4..9c50313842ec 100644
--- a/dev-python/numpy/numpy-1.2.1.ebuild
+++ b/dev-python/numpy/numpy-1.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.2.1.ebuild,v 1.2 2008/12/07 19:11:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.2.1.ebuild,v 1.3 2009/01/14 17:50:18 bicatali Exp $
NEED_PYTHON=2.4
@@ -81,22 +81,22 @@ src_unpack() {
cat >> site.cfg <<-EOF
[atlas]
include_dirs = $(pkg-config --cflags-only-I \
- cblas lapack | sed -e 's/^-I//' -e 's/ -I/:/g')
+ cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
library_dirs = $(pkg-config --libs-only-L \
- cblas lapack | sed -e \
+ cblas blas lapack | sed -e \
's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):/usr/$(get_libdir)
atlas_libs = $(pkg-config --libs-only-l \
- cblas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ cbas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
lapack_libs = $(pkg-config --libs-only-l \
lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
[blas_opt]
include_dirs = $(pkg-config --cflags-only-I \
cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
library_dirs = $(pkg-config --libs-only-L \
- cblas | sed -e 's/^-L//' -e 's/ -L/:/g' \
+ cblas blas | sed -e 's/^-L//' -e 's/ -L/:/g' \
-e 's/ //g'):/usr/$(get_libdir)
libraries = $(pkg-config --libs-only-l \
- cblas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
[lapack_opt]
library_dirs = $(pkg-config --libs-only-L \
lapack | sed -e 's/^-L//' -e 's/ -L/:/g' \