summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-11 06:23:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-11 06:23:59 +0000
commitf9c2527412820938e797bb6272f8c604010da470 (patch)
tree83ca559b3d108ec0ff017f64f0a72a9d53197e0e /dev-python/odfpy
parentBump (diff)
downloadgentoo-2-f9c2527412820938e797bb6272f8c604010da470.tar.gz
gentoo-2-f9c2527412820938e797bb6272f8c604010da470.tar.bz2
gentoo-2-f9c2527412820938e797bb6272f8c604010da470.zip
Bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/odfpy')
-rw-r--r--dev-python/odfpy/ChangeLog7
-rw-r--r--dev-python/odfpy/odfpy-0.9.6.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/odfpy/ChangeLog b/dev-python/odfpy/ChangeLog
index 0da199912afe..8028a1cca4a9 100644
--- a/dev-python/odfpy/ChangeLog
+++ b/dev-python/odfpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/odfpy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/odfpy/ChangeLog,v 1.8 2013/01/11 06:46:27 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/odfpy/ChangeLog,v 1.9 2013/03/11 06:23:59 patrick Exp $
+
+*odfpy-0.9.6 (11 Mar 2013)
+
+ 11 Mar 2013; Patrick Lauer <patrick@gentoo.org> +odfpy-0.9.6.ebuild:
+ Bump
*odfpy-0.9.5 (11 Jan 2013)
diff --git a/dev-python/odfpy/odfpy-0.9.6.ebuild b/dev-python/odfpy/odfpy-0.9.6.ebuild
new file mode 100644
index 000000000000..38875aafcc73
--- /dev/null
+++ b/dev-python/odfpy/odfpy-0.9.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/odfpy/odfpy-0.9.6.ebuild,v 1.1 2013/03/11 06:23:59 patrick Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python API and tools to manipulate OpenDocument files"
+HOMEPAGE="https://joinup.ec.europa.eu/software/odfpy/home http://pypi.python.org/pypi/odfpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PYTHON_MODNAME="odf"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-0.9.4-tests.patch"
+}
+
+src_test() {
+ cd tests || die
+ testing() {
+ local exit_status=0 test
+ for test in test*.py; do
+ einfo "Running ${test} ..."
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" "${test}"
+ [[ $? -ne 0 ]] && exit_status=1
+ done
+ return ${exit_status}
+ }
+ python_execute_function testing
+}