summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2012-05-16 21:35:37 +0000
committerMarien Zwart <marienz@gentoo.org>2012-05-16 21:35:37 +0000
commitd73aeb9c8d7a54d38421cca9e095fb15e9c5e69f (patch)
tree5a85612ecead2847ec354f8ce94fedd2f704d24d /dev-python/paste
parentRemoving unmask on last-rite selinux packages (diff)
downloadgentoo-2-d73aeb9c8d7a54d38421cca9e095fb15e9c5e69f.tar.gz
gentoo-2-d73aeb9c8d7a54d38421cca9e095fb15e9c5e69f.tar.bz2
gentoo-2-d73aeb9c8d7a54d38421cca9e095fb15e9c5e69f.zip
Fix tests on pypy, remove test that accesses the network (bug #339252).
(Portage version: 2.2.0_alpha105/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/ChangeLog8
-rw-r--r--dev-python/paste/files/paste-1.7.5.1-fix-tests-for-pypy.patch24
-rw-r--r--dev-python/paste/paste-1.7.5.1.ebuild11
3 files changed, 38 insertions, 5 deletions
diff --git a/dev-python/paste/ChangeLog b/dev-python/paste/ChangeLog
index 95a2a873646d..0e32b8680135 100644
--- a/dev-python/paste/ChangeLog
+++ b/dev-python/paste/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/paste
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/ChangeLog,v 1.16 2011/05/24 21:02:58 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/ChangeLog,v 1.17 2012/05/16 21:35:37 marienz Exp $
+
+ 16 May 2012; Marien Zwart <marienz@gentoo.org>
+ +files/paste-1.7.5.1-fix-tests-for-pypy.patch, paste-1.7.5.1.ebuild:
+ Fix tests on pypy, remove test that accesses the network (bug #339252).
24 May 2011; Markus Meier <maekke@gentoo.org> paste-1.7.5.1.ebuild:
x86 stable, bug #365537
diff --git a/dev-python/paste/files/paste-1.7.5.1-fix-tests-for-pypy.patch b/dev-python/paste/files/paste-1.7.5.1-fix-tests-for-pypy.patch
new file mode 100644
index 000000000000..b5e9430c3bb9
--- /dev/null
+++ b/dev-python/paste/files/paste-1.7.5.1-fix-tests-for-pypy.patch
@@ -0,0 +1,24 @@
+Ignore the exception detail for two exceptions that are slightly
+different on pypy.
+
+diff -r 7f90a96378ed tests/test_template.txt
+--- a/tests/test_template.txt Mon Mar 05 21:14:08 2012 +0100
++++ b/tests/test_template.txt Wed May 16 23:29:46 2012 +0200
+@@ -6,7 +6,7 @@
+ 'Hi Ian'
+ >>> Template('Hi {{repr(name)}}').substitute(name='Ian')
+ "Hi 'Ian'"
+- >>> Template('Hi {{name+1}}').substitute(name='Ian')
++ >>> Template('Hi {{name+1}}').substitute(name='Ian') #doctest: +IGNORE_EXCEPTION_DETAIL
+ Traceback (most recent call last):
+ ...
+ TypeError: cannot concatenate 'str' and 'int' objects at line 1 column 6
+@@ -125,7 +125,7 @@
+ >>> sub('{{default x=1}}{{x}}')
+ '1'
+ >>> # The normal case:
+- >>> sub('{{x}}')
++ >>> sub('{{x}}') #doctest: +IGNORE_EXCEPTION_DETAIL
+ Traceback (most recent call last):
+ ...
+ NameError: name 'x' is not defined at line 1 column 3
diff --git a/dev-python/paste/paste-1.7.5.1.ebuild b/dev-python/paste/paste-1.7.5.1.ebuild
index 8ea8adc8fb4d..a652fbdd02c9 100644
--- a/dev-python/paste/paste-1.7.5.1.ebuild
+++ b/dev-python/paste/paste-1.7.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/paste-1.7.5.1.ebuild,v 1.4 2011/05/24 21:02:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/paste-1.7.5.1.ebuild,v 1.5 2012/05/16 21:35:37 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -8,7 +8,7 @@ SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
DISTUTILS_SRC_TEST="nosetests"
-inherit distutils
+inherit distutils eutils
MY_PN="Paste"
MY_P="${MY_PN}-${PV}"
@@ -40,6 +40,11 @@ src_prepare() {
-e "s/test_deep/_&/" \
-e "s/test_static_parser/_&/" \
-i tests/test_urlparser.py || die "sed failed"
+
+ # Remove a test that runs against the paste website.
+ rm tests/test_proxy.py
+
+ epatch "${FILESDIR}/${P}-fix-tests-for-pypy.patch"
}
src_compile() {