summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-09-23 12:21:14 +0000
committerJustin Lecher <jlec@gentoo.org>2013-09-23 12:21:14 +0000
commitf6b18084f8bb1deb6054966cda0c000ea2fafbdb (patch)
treeaaeb384ae1c13737aca924d6aa0be78422f50874 /dev-python/pmw/pmw-2.0.0-r2.ebuild
parentdev-python/pmw: Fix patch and more pyton eclass funtion uses (diff)
downloadgentoo-2-f6b18084f8bb1deb6054966cda0c000ea2fafbdb.tar.gz
gentoo-2-f6b18084f8bb1deb6054966cda0c000ea2fafbdb.tar.bz2
gentoo-2-f6b18084f8bb1deb6054966cda0c000ea2fafbdb.zip
dev-python/pmw: Fix patch and more pyton eclass funtion uses
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/pmw/pmw-2.0.0-r2.ebuild')
-rw-r--r--dev-python/pmw/pmw-2.0.0-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pmw/pmw-2.0.0-r2.ebuild b/dev-python/pmw/pmw-2.0.0-r2.ebuild
new file mode 100644
index 000000000000..cbf70e58ad63
--- /dev/null
+++ b/dev-python/pmw/pmw-2.0.0-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-2.0.0-r2.ebuild,v 1.1 2013/09/23 12:21:14 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_2,3_3} )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1
+
+MY_P="Pmw.${PV}"
+
+DESCRIPTION="Toolkit for building high-level compound widgets in Python using the Tkinter module"
+HOMEPAGE="http://pmw.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="py3"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+DEPEND="!dev-python/pmw:0"
+RDEPEND="${DEPEND}"
+# http://sourceforge.net/p/pmw/bugs/39/
+RESTRICT="test"
+
+S="${WORKDIR}/src"
+
+DOCS="Pmw/README"
+
+python_prepare() {
+ distutils-r1_python_prepare
+ 2to3 Pmw
+}
+
+python_test() {
+ cd "${BUILD_DIR}/lib/Pmw/Pmw_2_0_0/" || die
+ PYTHONPATH=PYTHONPATH=tests:../../
+ cp tests/{flagup.bmp,earthris.gif} . || die
+ for test in tests/*_test.py; do
+ echo "running test "$test
+ PYTHONPATH=tests:../../ "${PYTHON}" $test || die
+ done
+}
+
+python_install_all() {
+ local DIR="Pmw/Pmw_2_0_0"
+
+ if use doc; then
+ dohtml -a html,gif,py "${DIR}"/doc/*
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins "${DIR}"/demos/*
+ fi
+
+ distutils-r1_python_install_all
+}