summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-04-16 08:00:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-04-16 08:00:45 +0000
commit199b4ba59bdef199b0a564761e8dad1f988c2590 (patch)
tree619539cd274aebae82205617ebc26a4768e5bec9 /dev-python/psutil
parentBump (diff)
downloadgentoo-2-199b4ba59bdef199b0a564761e8dad1f988c2590.tar.gz
gentoo-2-199b4ba59bdef199b0a564761e8dad1f988c2590.tar.bz2
gentoo-2-199b4ba59bdef199b0a564761e8dad1f988c2590.zip
Bump
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/psutil')
-rw-r--r--dev-python/psutil/ChangeLog9
-rw-r--r--dev-python/psutil/psutil-0.7.0.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-python/psutil/ChangeLog b/dev-python/psutil/ChangeLog
index 72468ee0c883..6ee47789a9d2 100644
--- a/dev-python/psutil/ChangeLog
+++ b/dev-python/psutil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/psutil
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/ChangeLog,v 1.15 2012/11/20 20:54:11 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/ChangeLog,v 1.16 2013/04/16 08:00:45 patrick Exp $
+
+*psutil-0.7.0 (16 Apr 2013)
+
+ 16 Apr 2013; Patrick Lauer <patrick@gentoo.org> +psutil-0.7.0.ebuild:
+ Bump
20 Nov 2012; Agostino Sarubbo <ago@gentoo.org> psutil-0.6.1.ebuild:
Stable for x86, wrt bug #441286
diff --git a/dev-python/psutil/psutil-0.7.0.ebuild b/dev-python/psutil/psutil-0.7.0.ebuild
new file mode 100644
index 000000000000..8696555181e3
--- /dev/null
+++ b/dev-python/psutil/psutil-0.7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/psutil-0.7.0.ebuild,v 1.1 2013/04/16 08:00:45 patrick Exp $
+
+EAPI="4"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_TESTS_RESTRICTED_ABIS="3.*"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils
+
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="http://code.google.com/p/psutil/ http://pypi.python.org/pypi/psutil"
+SRC_URI="http://psutil.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# A broken test
+RESTRICT="test"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" test/test_psutil.py
+ }
+ python_execute_function testing
+}