summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2013-06-08 14:54:22 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2013-06-08 14:54:22 +0000
commit7d6ad8ace1b0e41f677bcd618db202521957d7b9 (patch)
treed4a9c46fc920b071bcbe074cb86bd74990a5ab38 /dev-python/pyacoustid
parentrevbump -> distutils-r1, deps upgraded, removed 1.6.1 (diff)
downloadgentoo-2-7d6ad8ace1b0e41f677bcd618db202521957d7b9.tar.gz
gentoo-2-7d6ad8ace1b0e41f677bcd618db202521957d7b9.tar.bz2
gentoo-2-7d6ad8ace1b0e41f677bcd618db202521957d7b9.zip
Version bump and conversion to EAPI5
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 7B087241)
Diffstat (limited to 'dev-python/pyacoustid')
-rw-r--r--dev-python/pyacoustid/ChangeLog10
-rw-r--r--dev-python/pyacoustid/pyacoustid-1.0.0.ebuild22
2 files changed, 30 insertions, 2 deletions
diff --git a/dev-python/pyacoustid/ChangeLog b/dev-python/pyacoustid/ChangeLog
index cc04cac0f384..fae732766c58 100644
--- a/dev-python/pyacoustid/ChangeLog
+++ b/dev-python/pyacoustid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyacoustid
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyacoustid/ChangeLog,v 1.3 2012/05/30 13:00:45 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyacoustid/ChangeLog,v 1.4 2013/06/08 14:54:22 sochotnicky Exp $
+
+*pyacoustid-1.0.0 (08 Jun 2013)
+
+ 08 Jun 2013; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ +pyacoustid-1.0.0.ebuild:
+ Version bump and conversion to EAPI5
30 May 2012; Kacper Kowalik <xarthisius@gentoo.org> pyacoustid-0.7.ebuild:
Correct dependencies
diff --git a/dev-python/pyacoustid/pyacoustid-1.0.0.ebuild b/dev-python/pyacoustid/pyacoustid-1.0.0.ebuild
new file mode 100644
index 000000000000..41a4216ba5df
--- /dev/null
+++ b/dev-python/pyacoustid/pyacoustid-1.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyacoustid/pyacoustid-1.0.0.ebuild,v 1.1 2013/06/08 14:54:22 sochotnicky Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for Chromaprint acoustic fingerprinting and the Acoustid API"
+HOMEPAGE="http://pypi.python.org/pypi/pyacoustid"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="media-libs/chromaprint
+ dev-python/audioread[${PYTHON_USEDEP}]"