summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-21 14:34:31 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-21 14:34:31 +0000
commit191c3500e3658c4ebc52ff32c6b30f4571df4554 (patch)
tree2cf2a92b9e1fc17ac5842577b075d3802285b1a7 /dev-python/pycairo
parentVersion bump. (diff)
downloadgentoo-2-191c3500e3658c4ebc52ff32c6b30f4571df4554.tar.gz
gentoo-2-191c3500e3658c4ebc52ff32c6b30f4571df4554.tar.bz2
gentoo-2-191c3500e3658c4ebc52ff32c6b30f4571df4554.zip
drop py2.6 add py3.4, patches to fix configure failure under py3.4, patch courtesy of Hristo Venev via Bug #504342 (early March)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/ChangeLog10
-rw-r--r--dev-python/pycairo/files/pycairo-1.10.0-waf-py3_4.patch11
-rw-r--r--dev-python/pycairo/files/pycairo-1.10.0-waf-unpack.patch12
-rw-r--r--dev-python/pycairo/pycairo-1.10.0-r4.ebuild18
4 files changed, 43 insertions, 8 deletions
diff --git a/dev-python/pycairo/ChangeLog b/dev-python/pycairo/ChangeLog
index 56061449fd44..723f82ca268c 100644
--- a/dev-python/pycairo/ChangeLog
+++ b/dev-python/pycairo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pycairo
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.144 2013/09/05 18:46:22 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.145 2014/05/21 14:34:31 idella4 Exp $
+
+ 21 May 2014; Ian Delaney <idella4@gentoo.org>
+ +files/pycairo-1.10.0-waf-py3_4.patch, +files/pycairo-1.10.0-waf-unpack.patch,
+ pycairo-1.10.0-r4.ebuild:
+ drop py2.6 add py3.4, patches to fix configure failure under py3.4, patch
+ courtesy of Hristo Venev via Bug #504342 (early March)
05 Sep 2013; Michał Górny <mgorny@gentoo.org> pycairo-1.10.0-r4.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/dev-python/pycairo/files/pycairo-1.10.0-waf-py3_4.patch b/dev-python/pycairo/files/pycairo-1.10.0-waf-py3_4.patch
new file mode 100644
index 000000000000..6e79db9ba272
--- /dev/null
+++ b/dev-python/pycairo/files/pycairo-1.10.0-waf-py3_4.patch
@@ -0,0 +1,11 @@
+--- a/waflib/Tools/python.py
++++ b/waflib/Tools/python.py
+@@ -169,7 +169,7 @@
+ conf.find_program('python-config-%s'%num,var='PYTHON_CONFIG',mandatory=False)
+ includes=[]
+ if conf.env.PYTHON_CONFIG:
+- for incstr in conf.cmd_and_log(conf.env.PYTHON+[conf.env.PYTHON_CONFIG,'--includes']).strip().split():
++ for incstr in conf.cmd_and_log([conf.env.PYTHON_CONFIG,'--includes']).strip().split():
+ if(incstr.startswith('-I')or incstr.startswith('/I')):
+ incstr=incstr[2:]
+ if incstr not in includes:
diff --git a/dev-python/pycairo/files/pycairo-1.10.0-waf-unpack.patch b/dev-python/pycairo/files/pycairo-1.10.0-waf-unpack.patch
new file mode 100644
index 000000000000..7d54ba160d68
--- /dev/null
+++ b/dev-python/pycairo/files/pycairo-1.10.0-waf-unpack.patch
@@ -0,0 +1,12 @@
+--- a/waf
++++ b/waf
+@@ -153,6 +153,9 @@
+ return dir
+
+ wafdir = find_lib()
++if sys.argv[1:] == ['unpack']:
++ print(wafdir)
++ exit()
+ sys.path.insert(0, wafdir)
+ from waflib.Tools.c_config import MACRO_TO_DESTOS
+ MACRO_TO_DESTOS['__POWERPC__'] = 'darwin'
diff --git a/dev-python/pycairo/pycairo-1.10.0-r4.ebuild b/dev-python/pycairo/pycairo-1.10.0-r4.ebuild
index ec9c2f7c205a..a3c355129bb8 100644
--- a/dev-python/pycairo/pycairo-1.10.0-r4.ebuild
+++ b/dev-python/pycairo/pycairo-1.10.0-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.10.0-r4.ebuild,v 1.18 2013/09/05 18:46:22 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.10.0-r4.ebuild,v 1.19 2014/05/21 14:34:31 idella4 Exp $
EAPI="5"
-PYTHON_COMPAT=( python2_{6,7} python3_{2,3} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
inherit eutils python-r1 waf-utils
@@ -27,8 +27,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# Note: xpyb is used as the C header, not Python modules
RDEPEND="${PYTHON_DEPS}
>=x11-libs/cairo-1.10.0[svg?,xcb?]
- xcb? ( x11-libs/xpyb )
-"
+ xcb? ( x11-libs/xpyb )"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
@@ -40,6 +39,7 @@ src_prepare() {
rm -f src/config.h || die
epatch "${FILESDIR}/${PN}-1.10.0-svg_check.patch"
epatch "${FILESDIR}/${PN}-1.10.0-xpyb.patch"
+ epatch "${FILESDIR}/${PN}-1.10.0-waf-unpack.patch"
epatch "${FILESDIR}"/py2cairo-1.10.0-ppc-darwin.patch
popd > /dev/null
@@ -51,8 +51,14 @@ src_prepare() {
popd > /dev/null
preparation() {
- if [[ ${EPYTHON} == python3.* ]]; then
+ if python_is_python3; then
cp -r -l "${WORKDIR}/pycairo-${PYCAIRO_PYTHON3_VERSION}" "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" > /dev/null
+ wafdir="$(./waf unpack)"
+ pushd "${wafdir}" > /dev/null
+ epatch "${FILESDIR}/${PN}-1.10.0-waf-py3_4.patch"
+ popd > /dev/null
+ popd > /dev/null
else
cp -r -l "${WORKDIR}/py2cairo-${PYCAIRO_PYTHON2_VERSION}" "${BUILD_DIR}" || die
fi