summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-15 18:03:11 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-15 18:03:11 +0000
commite45adcfec61b74bcb12ae75361a715f39c96da8c (patch)
treea011d7eb3032c51b1923cae757a20f4adc1eca95 /dev-python/pycparser
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-e45adcfec61b74bcb12ae75361a715f39c96da8c.tar.gz
gentoo-2-e45adcfec61b74bcb12ae75361a715f39c96da8c.tar.bz2
gentoo-2-e45adcfec61b74bcb12ae75361a715f39c96da8c.zip
Version Bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/pycparser')
-rw-r--r--dev-python/pycparser/ChangeLog7
-rw-r--r--dev-python/pycparser/pycparser-2.14.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/pycparser/ChangeLog b/dev-python/pycparser/ChangeLog
index ffcc574bcbf3..f9eb9a8f4de1 100644
--- a/dev-python/pycparser/ChangeLog
+++ b/dev-python/pycparser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycparser
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycparser/ChangeLog,v 1.38 2015/06/07 15:23:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycparser/ChangeLog,v 1.39 2015/06/15 18:03:11 jlec Exp $
+
+*pycparser-2.14 (15 Jun 2015)
+
+ 15 Jun 2015; Justin Lecher <jlec@gentoo.org> +pycparser-2.14.ebuild:
+ Version Bump
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-python/pycparser/pycparser-2.14.ebuild b/dev-python/pycparser/pycparser-2.14.ebuild
new file mode 100644
index 000000000000..2f3624b90801
--- /dev/null
+++ b/dev-python/pycparser/pycparser-2.14.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycparser/pycparser-2.14.ebuild,v 1.1 2015/06/15 18:03:11 jlec Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="C parser and AST generator written in Python"
+HOMEPAGE="https://github.com/eliben/pycparser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile() {
+ distutils-r1_python_compile
+ pushd "${BUILD_DIR}/lib/pycparser" > /dev/null || die
+ "${PYTHON}" _build_tables.py || die
+ popd > /dev/null || die
+}
+
+python_test() {
+ nosetests || die
+}