summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-21 12:19:11 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-21 12:19:11 +0000
commitbeaeb9ea480af296919401d378b64486c3e4b0d8 (patch)
treeccd762eec85fa22af24cb5c5cd8de0178f9c0e8d /dev-python/pycxx
parentStable on amd64 wrt bug #355713 (diff)
downloadgentoo-2-beaeb9ea480af296919401d378b64486c3e4b0d8.tar.gz
gentoo-2-beaeb9ea480af296919401d378b64486c3e4b0d8.tar.bz2
gentoo-2-beaeb9ea480af296919401d378b64486c3e4b0d8.zip
Version bump.
(Portage version: 2.2.0_alpha24_p17/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/ChangeLog8
-rw-r--r--dev-python/pycxx/pycxx-6.2.2.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/pycxx/ChangeLog b/dev-python/pycxx/ChangeLog
index d96cdad78070..c1e38a7a7f57 100644
--- a/dev-python/pycxx/ChangeLog
+++ b/dev-python/pycxx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pycxx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/ChangeLog,v 1.23 2011/02/05 22:48:51 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/ChangeLog,v 1.24 2011/02/21 12:19:11 arfrever Exp $
+
+*pycxx-6.2.2 (21 Feb 2011)
+
+ 21 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pycxx-6.1.1.ebuild, -pycxx-6.2.1.ebuild, +pycxx-6.2.2.ebuild:
+ Version bump.
05 Feb 2011; Markus Meier <maekke@gentoo.org> pycxx-6.2.1-r1.ebuild:
add ~arm, bug #350648
diff --git a/dev-python/pycxx/pycxx-6.2.2.ebuild b/dev-python/pycxx/pycxx-6.2.2.ebuild
new file mode 100644
index 000000000000..f81bad9de708
--- /dev/null
+++ b/dev-python/pycxx/pycxx-6.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.2.2.ebuild,v 1.1 2011/02/21 12:19:11 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit eutils distutils
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+PYTHON_MODNAME="CXX"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.1.0-setup.py.patch"
+ epatch "${FILESDIR}/${PN}-6.1.0-python-3.patch"
+ epatch "${FILESDIR}/${PN}-6.1.0-C_compatible_headers.patch"
+
+ sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml -r Doc/ || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples/python-2
+ dodoc Demo/Python2/* || die "dodoc failed"
+ docinto examples/python-3
+ dodoc Demo/Python3/* || die "dodoc failed"
+ fi
+}