summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 16:57:28 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 16:57:28 +0000
commit710486be18d3fe8c882e959c33fddb4badd3b3c5 (patch)
tree00d5956429c9abd8ac3120e4b8f6818cb7b1c646 /dev-python/pygobject
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-710486be18d3fe8c882e959c33fddb4badd3b3c5.tar.gz
gentoo-2-710486be18d3fe8c882e959c33fddb4badd3b3c5.tar.bz2
gentoo-2-710486be18d3fe8c882e959c33fddb4badd3b3c5.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-python/pygobject')
-rw-r--r--dev-python/pygobject/ChangeLog8
-rwxr-xr-xdev-python/pygobject/files/pygobject-3.7.90-make_check.patch86
-rw-r--r--dev-python/pygobject/pygobject-3.8.0.ebuild107
3 files changed, 200 insertions, 1 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index 447c400ca40b..741de9f591a5 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.203 2013/03/28 15:53:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.204 2013/03/28 16:57:28 pacho Exp $
+
+*pygobject-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/pygobject-3.7.90-make_check.patch, +pygobject-3.8.0.ebuild:
+ Version bump for Gnome 3.8
28 Mar 2013; Agostino Sarubbo <ago@gentoo.org> pygobject-2.28.6-r53.ebuild,
pygobject-3.2.2-r1.ebuild:
diff --git a/dev-python/pygobject/files/pygobject-3.7.90-make_check.patch b/dev-python/pygobject/files/pygobject-3.7.90-make_check.patch
new file mode 100755
index 000000000000..74db7757f735
--- /dev/null
+++ b/dev-python/pygobject/files/pygobject-3.7.90-make_check.patch
@@ -0,0 +1,86 @@
+From 319d6d68a398d326ef95e39f494da7c514facf81 Mon Sep 17 00:00:00 2001
+From: Sobhan Mohammadpour <sobhanmohammadpour1@yahoo.fr>
+Date: Fri, 8 Mar 2013 08:25:58 +0330
+Subject: [PATCH] pygobject-3.7.90-make check
+
+originaly by [Alexandre Rostovtsev <tetromino@gmail.com>
+don't build tests unless it's needed
+
+---
+ tests/Makefile.am | 12 ++++++------
+ tests/runtests.py | 3 +++
+ 2 files changed, 9 insertions(+), 6 deletions(-)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 287542d..2cc0da9 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -1,5 +1,5 @@
+ CLEANFILES =
+-noinst_LTLIBRARIES = libgimarshallingtests.la
++check_LTLIBRARIES = libgimarshallingtests.la
+ test_typelibs = GIMarshallingTests-1.0.typelib
+
+ nodist_libgimarshallingtests_la_SOURCES = $(GI_DATADIR)/tests/gimarshallingtests.c $(GI_DATADIR)/tests/gimarshallingtests.h
+@@ -23,7 +23,7 @@ GIMarshallingTests-1.0.typelib: GIMarshallingTests-1.0.gir Makefile
+
+ # regress.c needs cairo
+ if ENABLE_CAIRO
+-noinst_LTLIBRARIES += libregress.la
++check_LTLIBRARIES += libregress.la
+ test_typelibs += Regress-1.0.typelib
+ nodist_libregress_la_SOURCES = $(GI_DATADIR)/tests/regress.c $(GI_DATADIR)/tests/regress.h
+ libregress_la_CFLAGS = $(GIO_CFLAGS) $(CAIRO_CFLAGS)
+@@ -52,7 +52,7 @@ gschemas.compiled: org.gnome.test.gschema.xml
+
+ CLEANFILES += Regress-1.0.gir Regress-1.0.typelib GIMarshallingTests-1.0.gir GIMarshallingTests-1.0.typelib gschemas.compiled
+
+-noinst_LTLIBRARIES += testhelper.la
++check_LTLIBRARIES += testhelper.la
+
+ testhelper_la_CFLAGS = -I$(top_srcdir)/gi/_gobject -I$(top_srcdir)/gi/_glib $(PYTHON_INCLUDES) $(GLIB_CFLAGS)
+ testhelper_la_LDFLAGS = -module -avoid-version
+@@ -72,7 +72,7 @@ testhelper.la: $(testhelper_la_OBJECTS) $(testhelper_la_DEPENDENCIES)
+ test -L $@ || $(LN_S) .libs/$@ $@
+
+
+-all: $(LTLIBRARIES:.la=.so)
++all: $(check_LTLIBRARIES:.la=.so)
+
+ EXTRA_DIST = \
+ compathelper.py \
+@@ -116,7 +116,7 @@ EXTRA_DIST = \
+ $(NULL)
+
+ clean-local:
+- rm -f $(LTLIBRARIES:.la=.so) file.txt~
++ rm -f $(check_LTLIBRARIES:.la=.so) file.txt~
+
+ DBUS_LAUNCH=$(shell which dbus-launch)
+ RUN_TESTS_ENV_VARS= \
+@@ -130,7 +130,7 @@ RUN_TESTS_ENV_VARS= \
+
+ # pygtkcompat tests need to be run in a separate process as they
+ # clobber global name space
+-check-local: $(LTLIBRARIES:.la=.so) $(test_typelibs) gschemas.compiled
++check-local: $(check_LTLIBRARIES:.la=.so) $(test_typelibs) gschemas.compiled
+ @echo " CHECK Pyflakes"
+ @if type pyflakes >/dev/null 2>&1; then pyflakes $(top_srcdir); else echo "skipped, pyflakes not installed"; fi
+ @if test -z "$$SKIP_PEP8"; then \
+diff --git a/tests/runtests.py b/tests/runtests.py
+index d3a4f47..5a53d3f 100755
+--- a/tests/runtests.py
++++ b/tests/runtests.py
+@@ -54,6 +54,9 @@ if sys.version_info[:2] == (2, 6):
+ if sys.version_info[:2] == (2, 7):
+ unittest.TestCase.assertRaisesRegex = unittest.TestCase.assertRaisesRegexp
+
++# Some tests fail with translated messages.
++os.environ["LC_ALL"] = "C"
++
+ if '--help' in sys.argv:
+ print("Usage: ./runtests.py <testfiles>")
+ sys.exit(0)
+--
+1.8.1.2
+
diff --git a/dev-python/pygobject/pygobject-3.8.0.ebuild b/dev-python/pygobject/pygobject-3.8.0.ebuild
new file mode 100644
index 000000000000..2c6bc62bda39
--- /dev/null
+++ b/dev-python/pygobject/pygobject-3.8.0.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-3.8.0.ebuild,v 1.1 2013/03/28 16:57:28 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+inherit autotools eutils gnome2 python-r1 virtualx
+
+DESCRIPTION="GLib's GObject library bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2.1+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+cairo examples test +threads"
+
+REQUIRED_USE="test? ( cairo )"
+
+COMMON_DEPEND=">=dev-libs/glib-2.31.0:2
+ >=dev-libs/gobject-introspection-1.34.1.1
+ virtual/libffi:=
+ cairo? ( >=dev-python/pycairo-1.10.0[${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
+"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/cairo[glib]
+ virtual/pkgconfig
+ test? (
+ dev-libs/atk[introspection]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ virtual/python-unittest2[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+
+# We now disable introspection support in slot 2 per upstream recommendation
+# (see https://bugzilla.gnome.org/show_bug.cgi?id=642048#c9); however,
+# older versions of slot 2 installed their own site-packages/gi, and
+# slot 3 will collide with them.
+RDEPEND="${COMMON_DEPEND}
+ !<dev-python/pygtk-2.13
+ !<dev-python/pygobject-2.28.6-r50:2[introspection]"
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog* NEWS README"
+ # Hard-enable libffi support since both gobject-introspection and
+ # glib-2.29.x rdepend on it anyway
+ # docs disabled by upstream default since they are very out of date
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --with-ffi
+ $(use_enable cairo)
+ $(use_enable threads thread)"
+
+ # Do not build tests if unneeded, bug #226345
+ epatch "${FILESDIR}/${PN}-3.7.90-make_check.patch"
+
+ # Run tests with older python too
+# epatch "${FILESDIR}/${PN}-3.7.90-run-tests-with-old-python.patch"
+
+ eautoreconf
+ gnome2_src_prepare
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+# FIXME: With python multiple ABI support, tests return 1 even when they pass
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ export GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
+
+ testing() {
+ export XDG_CACHE_HOME="${T}/${EPYTHON}"
+ run_in_build_dir Xemake check
+ unset XDG_CACHE_HOME
+ }
+ python_foreach_impl testing
+ unset GIO_USE_VFS
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+run_in_build_dir() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "$@"
+ popd > /dev/null
+}