summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-07-09 13:15:51 +0000
committerAli Polatel <hawking@gentoo.org>2007-07-09 13:15:51 +0000
commite8fbb502584967e65a2ed0962a4ebeca91a270f2 (patch)
treee0054ee4321e7254e0e6b8c57613c4c1a23c2fcd /dev-python/pylibpcap
parentBug 184513, keywording ~amd64. Also added fixlocalpod call to resolve collisi... (diff)
downloadgentoo-2-e8fbb502584967e65a2ed0962a4ebeca91a270f2.tar.gz
gentoo-2-e8fbb502584967e65a2ed0962a4ebeca91a270f2.tar.bz2
gentoo-2-e8fbb502584967e65a2ed0962a4ebeca91a270f2.zip
Apply fix from upstream to make pcap.findalldevs() work fine (bug #179342)
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'dev-python/pylibpcap')
-rw-r--r--dev-python/pylibpcap/ChangeLog6
-rw-r--r--dev-python/pylibpcap/files/pylibpcap-unknown_addr.patch13
-rw-r--r--dev-python/pylibpcap/pylibpcap-0.5.1.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/dev-python/pylibpcap/ChangeLog b/dev-python/pylibpcap/ChangeLog
index a7119fd4be3e..ee801b219dc7 100644
--- a/dev-python/pylibpcap/ChangeLog
+++ b/dev-python/pylibpcap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pylibpcap
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibpcap/ChangeLog,v 1.16 2007/04/01 10:02:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibpcap/ChangeLog,v 1.17 2007/07/09 13:15:51 hawking Exp $
+
+ 09 Jul 2007; Ali Polatel <hawking@gentoo.org>
+ +files/pylibpcap-unknown_addr.patch, pylibpcap-0.5.1.ebuild:
+ Apply fix from upstream to make pcap.findalldevs() work fine (bug #179342)
01 Apr 2007; Raúl Porcel <armin76@gentoo.org> pylibpcap-0.5.1.ebuild:
ia64 stable wrt bug 168330
diff --git a/dev-python/pylibpcap/files/pylibpcap-unknown_addr.patch b/dev-python/pylibpcap/files/pylibpcap-unknown_addr.patch
new file mode 100644
index 000000000000..babb4d0a1dc9
--- /dev/null
+++ b/dev-python/pylibpcap/files/pylibpcap-unknown_addr.patch
@@ -0,0 +1,13 @@
+--- pcap_interface.c.orig 2004-07-10 07:58:10.000000000 +0300
++++ pcap_interface.c 2007-07-09 13:40:18.000000000 +0300
+@@ -513,9 +513,7 @@
+ break;
+ #endif
+ default:
+- fprintf(stderr, "at line %d\n", __LINE__);
+- throw_exception(-1, "unsupported address family");
+- return NULL;
++ return PyString_FromFormat("<AF %d>", sa->sa_family);
+ case AF_UNSPEC:
+ Py_INCREF(Py_None);
+ return Py_None;
diff --git a/dev-python/pylibpcap/pylibpcap-0.5.1.ebuild b/dev-python/pylibpcap/pylibpcap-0.5.1.ebuild
index a320fb6213be..4d6821050df4 100644
--- a/dev-python/pylibpcap/pylibpcap-0.5.1.ebuild
+++ b/dev-python/pylibpcap/pylibpcap-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibpcap/pylibpcap-0.5.1.ebuild,v 1.7 2007/04/01 10:02:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibpcap/pylibpcap-0.5.1.ebuild,v 1.8 2007/07/09 13:15:51 hawking Exp $
inherit distutils eutils
@@ -21,6 +21,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${PN}-swig-1.3.29.patch"
+ epatch "${FILESDIR}/${PN}-unknown_addr.patch"
}
src_install() {