summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-18 18:11:20 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-18 18:11:20 +0000
commit62e1e5741676d3ec75e4f36ab7ac1d44d593e041 (patch)
treea05dc98fa38483bdc1724bada6ab6a5aa0cc53c0 /dev-python/pylint
parentDelete older ebuilds. (diff)
downloadgentoo-2-62e1e5741676d3ec75e4f36ab7ac1d44d593e041.tar.gz
gentoo-2-62e1e5741676d3ec75e4f36ab7ac1d44d593e041.tar.bz2
gentoo-2-62e1e5741676d3ec75e4f36ab7ac1d44d593e041.zip
Version bump.
(Portage version: 2.2.0_alpha17/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog9
-rw-r--r--dev-python/pylint/pylint-0.23.0.ebuild61
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index 43f622432b43..ff996a5e9300 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.79 2011/01/06 21:47:55 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.80 2011/01/18 18:11:20 arfrever Exp $
+
+*pylint-0.23.0 (18 Jan 2011)
+
+ 18 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pylint-0.21.0.ebuild, -pylint-0.21.1.ebuild, -pylint-0.21.2.ebuild,
+ +pylint-0.23.0.ebuild:
+ Version bump.
06 Jan 2011; Brent Baude <ranger@gentoo.org> pylint-0.21.3.ebuild:
Marking pylint-0.21.3 ppc for bug 341607
diff --git a/dev-python/pylint/pylint-0.23.0.ebuild b/dev-python/pylint/pylint-0.23.0.ebuild
new file mode 100644
index 000000000000..3fb4fdc2ad1c
--- /dev/null
+++ b/dev-python/pylint/pylint-0.23.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.23.0.ebuild,v 1.1 2011/01/18 18:11:20 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4"
+
+inherit distutils
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="http://www.logilab.org/projects/pylint/ http://pypi.python.org/pypi/pylint"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="examples"
+
+# Versions specified in __pkginfo__.py.
+RDEPEND=">=dev-python/logilab-common-0.53.0
+ >=dev-python/astng-0.21.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS="doc/*.txt"
+
+src_test() {
+ testing() {
+ # Test suite broken with Python 3.
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
+
+ PYTHONPATH="build/lib" pytest -v
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ distutils_src_install
+
+ doman man/{pylint,pyreverse}.1 || die "doman failed"
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc failed"
+ fi
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/pylint/test"
+ }
+ python_execute_function -q delete_tests
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ elog "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled."
+}