summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-07-28 13:47:22 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-07-28 13:47:22 +0000
commit8bd796ad445042c62d1e18906a2c7e745990d698 (patch)
tree0f3b0460969b012d82e3948a16fdb18dd0828a15 /dev-python/pyopengl
parentFixed typo. Thanks to HAGIHARA Yoshiaki and Nobuyuki MORIYA. (diff)
downloadgentoo-2-8bd796ad445042c62d1e18906a2c7e745990d698.tar.gz
gentoo-2-8bd796ad445042c62d1e18906a2c7e745990d698.tar.bz2
gentoo-2-8bd796ad445042c62d1e18906a2c7e745990d698.zip
freebsd compat patch to remove use of malloc.h (#140940)
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-python/pyopengl')
-rw-r--r--dev-python/pyopengl/ChangeLog8
-rw-r--r--dev-python/pyopengl/files/pyopengl-2.0.1.09-malloc.patch92
-rw-r--r--dev-python/pyopengl/pyopengl-2.0.1.09.ebuild6
3 files changed, 103 insertions, 3 deletions
diff --git a/dev-python/pyopengl/ChangeLog b/dev-python/pyopengl/ChangeLog
index d63beff52597..3f3a887d7de6 100644
--- a/dev-python/pyopengl/ChangeLog
+++ b/dev-python/pyopengl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyopengl
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopengl/ChangeLog,v 1.13 2005/12/11 22:43:22 spyderous Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopengl/ChangeLog,v 1.14 2006/07/28 13:47:22 liquidx Exp $
+
+ 28 Jul 2006; Alastair Tse <liquidx@gentoo.org>
+ +files/pyopengl-2.0.1.09-malloc.patch, pyopengl-2.0.1.09.ebuild:
+ freebsd compat patch to remove use of malloc.h (#140940)
11 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
pyopengl-2.0.1.09.ebuild:
diff --git a/dev-python/pyopengl/files/pyopengl-2.0.1.09-malloc.patch b/dev-python/pyopengl/files/pyopengl-2.0.1.09-malloc.patch
new file mode 100644
index 000000000000..4acbb89ce76e
--- /dev/null
+++ b/dev-python/pyopengl/files/pyopengl-2.0.1.09-malloc.patch
@@ -0,0 +1,92 @@
+--- PyOpenGL-2.0.1.09/src/Togl-1.5/tkWinPort.h Tue May 15 03:55:20 2001
++++ PyOpenGL-2.0.1.09/src/Togl-1.5/tkWinPort.h Sun Jul 16 06:51:23 2006
+@@ -22,7 +22,6 @@
+ #include <X11/Xatom.h>
+ #include <X11/Xutil.h>
+
+-#include <malloc.h>
+ #include <errno.h>
+ #include <ctype.h>
+ #include <math.h>
+--- PyOpenGL-2.0.1.09/src/Togl-1.5/winMain.c Tue May 15 03:55:20 2001
++++ PyOpenGL-2.0.1.09/src/Togl-1.5/winMain.c Sun Jul 16 06:51:23 2006
+@@ -18,7 +18,7 @@
+ #define WIN32_LEAN_AND_MEAN
+ #include <windows.h>
+ #undef WIN32_LEAN_AND_MEAN
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <locale.h>
+
+ /*
+--- PyOpenGL-2.0.1.09/src/gle/src/ex_angle.c Fri Mar 12 13:20:14 2004
++++ PyOpenGL-2.0.1.09/src/gle/src/ex_angle.c Sun Jul 16 06:51:23 2006
+@@ -20,7 +20,6 @@
+ #include <sys/types.h> /* Darwin has a bug that doesn't define u_short in */
+ #include <sys/malloc.h> /* malloc.h, so we have to get it through stdio.h. */
+ #else
+-#include <malloc.h>
+ #endif
+ #include <math.h>
+ #include <stdio.h>
+--- PyOpenGL-2.0.1.09/src/gle/src/ex_cut_round.c Fri Mar 12 13:20:14 2004
++++ PyOpenGL-2.0.1.09/src/gle/src/ex_cut_round.c Sun Jul 16 06:51:23 2006
+@@ -22,7 +22,6 @@
+ #include <sys/types.h> /* Darwin has a bug that doesn't define u_short in */
+ #include <sys/malloc.h> /* malloc.h, so we have to get it through stdio.h. */
+ #else
+-#include <malloc.h>
+ #endif
+ #include <math.h>
+ #include <stdio.h>
+--- PyOpenGL-2.0.1.09/src/gle/src/ex_raw.c Fri Mar 12 13:20:14 2004
++++ PyOpenGL-2.0.1.09/src/gle/src/ex_raw.c Sun Jul 16 06:51:23 2006
+@@ -19,7 +19,6 @@
+ #include <sys/types.h> /* Darwin has a bug that doesn't define u_short in */
+ #include <sys/malloc.h> /* malloc.h, so we have to get it through stdio.h. */
+ #else
+-#include <malloc.h>
+ #endif
+ #include <stdlib.h>
+ #include <math.h>
+--- PyOpenGL-2.0.1.09/src/gle/src/extrude.c Fri Mar 12 13:20:14 2004
++++ PyOpenGL-2.0.1.09/src/gle/src/extrude.c Sun Jul 16 06:51:23 2006
+@@ -18,7 +18,6 @@
+ #include <sys/types.h> /* Darwin has a bug that doesn't define u_short in */
+ #include <sys/malloc.h> /* malloc.h, so we have to get it through stdio.h. */
+ #else
+-#include <malloc.h>
+ #endif
+ #include <math.h>
+ #include <stdlib.h>
+--- PyOpenGL-2.0.1.09/src/gle/src/round_cap.c Fri Mar 12 13:20:14 2004
++++ PyOpenGL-2.0.1.09/src/gle/src/round_cap.c Sun Jul 16 06:51:23 2006
+@@ -16,7 +16,6 @@
+ #include <sys/types.h> /* Darwin has a bug that doesn't define u_short in */
+ #include <sys/malloc.h> /* malloc.h, so we have to get it through stdio.h. */
+ #else
+-#include <malloc.h>
+ #endif
+ #include <stdlib.h>
+ #include <math.h>
+--- PyOpenGL-2.0.1.09/src/gle/src/segment.c Fri Mar 12 13:20:14 2004
++++ PyOpenGL-2.0.1.09/src/gle/src/segment.c Sun Jul 16 06:51:23 2006
+@@ -18,7 +18,6 @@
+ #include <sys/types.h> /* Darwin has a bug that doesn't define u_short in */
+ #include <sys/malloc.h> /* malloc.h, so we have to get it through stdio.h. */
+ #else
+-#include <malloc.h>
+ #endif
+ #include <stdlib.h>
+ #include <math.h>
+--- PyOpenGL-2.0.1.09/src/gle/src/texgen.c Fri Mar 12 13:20:14 2004
++++ PyOpenGL-2.0.1.09/src/gle/src/texgen.c Sun Jul 16 06:51:23 2006
+@@ -15,7 +15,7 @@
+ #include <sys/types.h> /* Darwin has a bug that doesn't define u_short in */
+ #include <sys/malloc.h> /* malloc.h, so we have to get it through stdio.h. */
+ #else
+-#include <malloc.h>
++#include <stdlib.h>
+ #endif
+ #include <math.h>
+
diff --git a/dev-python/pyopengl/pyopengl-2.0.1.09.ebuild b/dev-python/pyopengl/pyopengl-2.0.1.09.ebuild
index 88b08538b9cd..83190786532e 100644
--- a/dev-python/pyopengl/pyopengl-2.0.1.09.ebuild
+++ b/dev-python/pyopengl/pyopengl-2.0.1.09.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopengl/pyopengl-2.0.1.09.ebuild,v 1.9 2006/07/05 05:25:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopengl/pyopengl-2.0.1.09.ebuild,v 1.10 2006/07/28 13:47:22 liquidx Exp $
MY_P=${P/pyopengl/PyOpenGL}
S=${WORKDIR}/${MY_P}
@@ -48,4 +48,8 @@ s:tk.getvar('tcl_version'):str(Tkinter.TclVersion):g;
s:tk.getvar('tk_library'):${TKLIBRARY}:g;
s:tk.getvar('tcl_library'):${TCLLIBRARY}:g;"""
sed -i -e "${SEDED}" togl_setup.py
+
+ # replace malloc.h with stdlib.h for freebsd (#140940)
+ cd "${S}"
+ epatch ${FILESDIR}/${P}-malloc.patch
}