summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-06-01 14:44:46 +0000
committerJeroen Roovers <jer@gentoo.org>2010-06-01 14:44:46 +0000
commitc0dc7e089ff6dd5fddca841a417c3790021e19bc (patch)
treedad9b2d39013fd27df4c77bafcefdd33cb7c8045 /dev-python/pyparted
parentDelete older ebuild. (diff)
downloadgentoo-2-c0dc7e089ff6dd5fddca841a417c3790021e19bc.tar.gz
gentoo-2-c0dc7e089ff6dd5fddca841a417c3790021e19bc.tar.bz2
gentoo-2-c0dc7e089ff6dd5fddca841a417c3790021e19bc.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/ChangeLog7
-rw-r--r--dev-python/pyparted/pyparted-3.4.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
index 30dac013236a..8605d3effa3d 100644
--- a/dev-python/pyparted/ChangeLog
+++ b/dev-python/pyparted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyparted
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.46 2010/05/20 17:55:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.47 2010/06/01 14:44:46 jer Exp $
+
+*pyparted-3.4 (01 Jun 2010)
+
+ 01 Jun 2010; Jeroen Roovers <jer@gentoo.org> +pyparted-3.4.ebuild:
+ Version bump.
20 May 2010; Jeroen Roovers <jer@gentoo.org> pyparted-3.1.ebuild:
Reverting x86 stabilisation (bug #316453).
diff --git a/dev-python/pyparted/pyparted-3.4.ebuild b/dev-python/pyparted/pyparted-3.4.ebuild
new file mode 100644
index 000000000000..c36876aaacff
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.4.ebuild,v 1.1 2010/06/01 14:44:46 jer Exp $
+
+EAPI="2"
+
+inherit autotools multilib python
+
+DESCRIPTION="Python bindings for sys-apps/parted"
+HOMEPAGE="https://fedorahosted.org/pyparted/"
+SRC_URI="https://fedorahosted.org/releases/p/y/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ sys-libs/ncurses
+ >=dev-lang/python-2.4
+ >=sys-apps/parted-2.1
+ dev-python/decorator
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/-avoid-version/& -shared /' src/Makefile.am || die "sed failed"
+ eautoreconf
+}
+
+src_install() {
+ python_need_rebuild
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog NEWS README TODO
+ # remove pointless libtool archive
+ python_version
+ rm -f "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/_pedmodule.la
+
+}