summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-03-02 01:00:13 +0000
committerJeroen Roovers <jer@gentoo.org>2010-03-02 01:00:13 +0000
commitf68b8bca103a1306bc988bc70a522377c538ec93 (patch)
tree14191c97c6df47b414868a6f97dfceca43120f53 /dev-python/pyparted
parentReplace eqawarn with ewarn - as it's present in all EAPIs (diff)
downloadgentoo-2-f68b8bca103a1306bc988bc70a522377c538ec93.tar.gz
gentoo-2-f68b8bca103a1306bc988bc70a522377c538ec93.tar.bz2
gentoo-2-f68b8bca103a1306bc988bc70a522377c538ec93.zip
Version bump.
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/ChangeLog7
-rw-r--r--dev-python/pyparted/pyparted-3.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
index 4bbbec52f16f..933c290672ef 100644
--- a/dev-python/pyparted/ChangeLog
+++ b/dev-python/pyparted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyparted
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.41 2010/02/24 16:00:59 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.42 2010/03/02 01:00:13 jer Exp $
+
+*pyparted-3.1 (02 Mar 2010)
+
+ 02 Mar 2010; Jeroen Roovers <jer@gentoo.org> +pyparted-3.1.ebuild:
+ Version bump.
*pyparted-3.0-r1 (24 Feb 2010)
diff --git a/dev-python/pyparted/pyparted-3.1.ebuild b/dev-python/pyparted/pyparted-3.1.ebuild
new file mode 100644
index 000000000000..675f29e2f394
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.1.ebuild,v 1.1 2010/03/02 01:00:13 jer Exp $
+
+EAPI="2"
+
+inherit autotools multilib python
+
+DESCRIPTION="Python bindings for sys-apps/parted"
+HOMEPAGE="https://fedorahosted.org/pyparted/"
+SRC_URI="http://fedorahosted.org/releases/p/y/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ sys-libs/ncurses
+ >=dev-lang/python-2.4
+ >=sys-apps/parted-2.1
+ dev-python/decorator
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/-avoid-version/& -shared /' src/Makefile.am || die "sed failed"
+ eautoreconf
+}
+
+src_install() {
+ python_need_rebuild
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog NEWS README TODO
+ # remove pointless libtool archive
+ python_version
+ rm -f "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/_pedmodule.la
+
+}