summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-13 20:28:50 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-13 20:28:50 +0000
commitfb11364ef968c14c81a8dc6600aed8dbc1d7a4bf (patch)
treef9cf3212f839251bd65f256aa84a34b8896c0576 /dev-python/pyqwt
parentFix building without berkdb support - bug #457138 (diff)
downloadgentoo-2-fb11364ef968c14c81a8dc6600aed8dbc1d7a4bf.tar.gz
gentoo-2-fb11364ef968c14c81a8dc6600aed8dbc1d7a4bf.tar.bz2
gentoo-2-fb11364ef968c14c81a8dc6600aed8dbc1d7a4bf.zip
dev-python/pyqwt: Move to new python eclasses
(Portage version: 2.2.0_alpha162/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'dev-python/pyqwt')
-rw-r--r--dev-python/pyqwt/ChangeLog10
-rw-r--r--dev-python/pyqwt/metadata.xml6
-rw-r--r--dev-python/pyqwt/pyqwt-5.2.0-r1.ebuild93
3 files changed, 104 insertions, 5 deletions
diff --git a/dev-python/pyqwt/ChangeLog b/dev-python/pyqwt/ChangeLog
index 69bea6fa7e22..092db531bb52 100644
--- a/dev-python/pyqwt/ChangeLog
+++ b/dev-python/pyqwt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyqwt
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/ChangeLog,v 1.19 2012/02/27 05:37:40 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/ChangeLog,v 1.20 2013/02/13 20:28:50 jlec Exp $
+
+*pyqwt-5.2.0-r1 (13 Feb 2013)
+
+ 13 Feb 2013; Justin Lecher <jlec@gentoo.org> +pyqwt-5.2.0-r1.ebuild,
+ metadata.xml:
+ Move to new python eclasses
27 Feb 2012; Patrick Lauer <patrick@gentoo.org> pyqwt-5.2.0.ebuild:
Restricting pypy
diff --git a/dev-python/pyqwt/metadata.xml b/dev-python/pyqwt/metadata.xml
index 4c7b8a7ec906..185fecc13a28 100644
--- a/dev-python/pyqwt/metadata.xml
+++ b/dev-python/pyqwt/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>python</herd>
-<herd>qt</herd>
-<longdescription lang="en">
+ <herd>python</herd>
+ <herd>qt</herd>
+ <longdescription lang="en">
PyQwt is a set of Python bindings for the Qwt C++ class library which
extends the Qt framework with widgets for scientific and engineering
applications. It provides a widget to plot 2-dimensional data and
diff --git a/dev-python/pyqwt/pyqwt-5.2.0-r1.ebuild b/dev-python/pyqwt/pyqwt-5.2.0-r1.ebuild
new file mode 100644
index 000000000000..4e05ffc290f9
--- /dev/null
+++ b/dev-python/pyqwt/pyqwt-5.2.0-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-5.2.0-r1.ebuild,v 1.1 2013/02/13 20:28:50 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit flag-o-matic python-r1
+
+MY_P="PyQwt-${PV}"
+DESCRIPTION="Python bindings for the Qwt library"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://pyqwt.sourceforge.net/"
+
+SLOT="5"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="debug doc examples svg"
+
+RDEPEND="
+ x11-libs/qwt:5[svg?]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+DEPEND="${DEPEND}
+ dev-python/sip[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}/configure"
+
+src_prepare() {
+ python_copy_sources
+ append-flags -fPIC
+}
+
+src_configure() {
+ configuration() {
+ local myonf=()
+ use debug && myconf+=( --debug )
+
+ cd "${BUILD_DIR}" || die
+ # '-j' option can be buggy.
+ "${PYTHON}" configure.py \
+ --extra-cflags="${CFLAGS}" \
+ --extra-cxxflags="${CXXFLAGS}" \
+ --extra-lflags="${LDFLAGS}" \
+ --disable-numarray \
+ --disable-numeric \
+ -I/usr/include/qwt5 \
+ -lqwt \
+ ${myconf[@]} \
+ || return 1
+
+ # Avoid stripping of the libraries.
+ sed -i -e "/strip/d" {iqt5qt4,qwt5qt4}/Makefile || die "sed failed"
+ }
+ python_foreach_impl configuration
+}
+
+src_compile() {
+ compilation() {
+ cd "${BUILD_DIR}" || die
+ default
+ }
+ python_foreach_impl compilation
+
+ if use doc; then
+ cd "${S}"/../sphinx || die
+ emake
+ fi
+}
+
+src_install() {
+ installation() {
+ cd "${BUILD_DIR}" || die
+ emake DESTDIR="${D}" install
+ }
+ python_foreach_impl installation
+
+ cd "${S}"/.. || die
+
+ dodoc ANNOUNCEMENT-${PV} README
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r sphinx/build/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins qt4examples/*
+ fi
+}