summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-12 23:43:47 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-12 23:43:47 +0000
commitc3c056028c1928323b29965ebdd42c64b660a727 (patch)
treeea0eebaeaa6fbd44757b336cacca826edb381ebe /dev-python/pysqlite
parentRemoved broken version (see bug #290481). (diff)
downloadgentoo-2-c3c056028c1928323b29965ebdd42c64b660a727.tar.gz
gentoo-2-c3c056028c1928323b29965ebdd42c64b660a727.tar.bz2
gentoo-2-c3c056028c1928323b29965ebdd42c64b660a727.zip
Version bump.
(Portage version: 14816-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pysqlite')
-rw-r--r--dev-python/pysqlite/ChangeLog8
-rw-r--r--dev-python/pysqlite/pysqlite-2.5.6.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-python/pysqlite/ChangeLog b/dev-python/pysqlite/ChangeLog
index bf75dbeccbf8..a49c1091b19b 100644
--- a/dev-python/pysqlite/ChangeLog
+++ b/dev-python/pysqlite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pysqlite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/ChangeLog,v 1.107 2009/11/11 15:38:40 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/ChangeLog,v 1.108 2009/11/12 23:43:47 arfrever Exp $
+
+*pysqlite-2.5.6 (13 Nov 2009)
+
+ 13 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pysqlite-2.5.6.ebuild:
+ Version bump.
11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> pysqlite-2.5.5-r1.ebuild:
stable sparc, bug 287572
diff --git a/dev-python/pysqlite/pysqlite-2.5.6.ebuild b/dev-python/pysqlite/pysqlite-2.5.6.ebuild
new file mode 100644
index 000000000000..6fabda9e9f12
--- /dev/null
+++ b/dev-python/pysqlite/pysqlite-2.5.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-2.5.6.ebuild,v 1.1 2009/11/12 23:43:47 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for the local database Sqlite"
+HOMEPAGE="http://code.google.com/p/pysqlite/ http://pypi.python.org/pypi/pysqlite"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="pysqlite"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="examples"
+
+DEPEND=">=dev-db/sqlite-3.1"
+RDEPEND=${DEPEND}
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="pysqlite2"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Don't install pysqlite2.test.
+ sed -i -e 's/, "pysqlite2.test"//' setup.py || die "sed setup.py failed"
+
+ # Fix encoding.
+ sed -i -e "s/\(coding: \)ISO-8859-1/\1utf-8/" lib/{__init__.py,dbapi2.py} || die "sed lib/{__init__.py,dbapi2.py} failed"
+
+ # Workaround to make tests work without installing them.
+ sed -i -e "s/pysqlite2.test/test/" lib/test/__init__.py || die "sed lib/test/__init__.py failed"
+}
+
+src_test() {
+ cd lib
+ testing() {
+ PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" -c "from test import test;import sys;sys.exit(test())"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ [[ -z "${ED}" ]] && local ED="${D}"
+ distutils_src_install
+
+ rm -rf "${ED}usr/pysqlite2-doc"
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/includes/sqlite3
+ fi
+}