summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-12-07 17:31:25 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-12-07 17:31:25 +0000
commit6a0a9db4ffdaf385da267da46b7392c49289e00c (patch)
treee421600dda5909e7dd0ae39301f8083deb20f332 /dev-python/pysrt/pysrt-0.5.1.ebuild
parentFix my thinko in the build patch. Thanks Vincent for reporting. (diff)
downloadgentoo-2-6a0a9db4ffdaf385da267da46b7392c49289e00c.tar.gz
gentoo-2-6a0a9db4ffdaf385da267da46b7392c49289e00c.tar.bz2
gentoo-2-6a0a9db4ffdaf385da267da46b7392c49289e00c.zip
New ebuild for dev-python/pysrt, a library used to edit or create SubRip files; fixes bug #493510, proxied commit for Nikoli whom provided the ebuilds and will maintain this package.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-python/pysrt/pysrt-0.5.1.ebuild')
-rw-r--r--dev-python/pysrt/pysrt-0.5.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pysrt/pysrt-0.5.1.ebuild b/dev-python/pysrt/pysrt-0.5.1.ebuild
new file mode 100644
index 000000000000..5252c517a8dc
--- /dev/null
+++ b/dev-python/pysrt/pysrt-0.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysrt/pysrt-0.5.1.ebuild,v 1.1 2013/12/07 17:31:25 tomwij Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.python.org/pypi/pysrt"
+# does not have tests/static/ # SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/byroot/pysrt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/charade[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+),${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests --with-coverage --cover-package=pysrt \
+ || die "Tests failed under ${EPYTHON}"
+}
+
+src_install() {
+ rm -rf "${S}/tests" || die
+
+ distutils-r1_src_install
+}
+
+python_install() {
+ rm -rf "${BUILD_DIR}/lib/tests" || die
+
+ distutils-r1_python_install
+}