summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-16 19:24:48 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-16 19:24:48 +0000
commit783000ef0812cad155292c4d1e6ffba0ffc69963 (patch)
treee34b9c72cb999cc62b82610f89d8b73cba848555 /dev-python/pysvn
parentDelete older ebuild. (diff)
downloadgentoo-2-783000ef0812cad155292c4d1e6ffba0ffc69963.tar.gz
gentoo-2-783000ef0812cad155292c4d1e6ffba0ffc69963.tar.bz2
gentoo-2-783000ef0812cad155292c4d1e6ffba0ffc69963.zip
Version bump (bug #338897). Respect LDFLAGS (bug #339967).
(Portage version: 2.2_rc97_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/ChangeLog9
-rw-r--r--dev-python/pysvn/pysvn-1.7.4.ebuild105
2 files changed, 113 insertions, 1 deletions
diff --git a/dev-python/pysvn/ChangeLog b/dev-python/pysvn/ChangeLog
index 13d1c63f62b8..f7c24e508b41 100644
--- a/dev-python/pysvn/ChangeLog
+++ b/dev-python/pysvn/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pysvn
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.11 2010/09/30 08:47:31 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.12 2010/10/16 19:24:48 arfrever Exp $
+
+*pysvn-1.7.4 (16 Oct 2010)
+
+ 16 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -files/pysvn-1.7.0-darwin-freebsd.patch, -pysvn-1.7.2.ebuild,
+ +pysvn-1.7.4.ebuild:
+ Version bump (bug #338897). Respect LDFLAGS (bug #339967).
30 Sep 2010; Fabian Groffen <grobian@gentoo.org> pysvn-1.7.2.ebuild:
Fixed pycxx detection in Prefix, marked ~x86-solaris, ~x86-linux
diff --git a/dev-python/pysvn/pysvn-1.7.4.ebuild b/dev-python/pysvn/pysvn-1.7.4.ebuild
new file mode 100644
index 000000000000..9ddf19bd4470
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.7.4.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.4.ebuild,v 1.1 2010/10/16 19:24:48 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="http://pysvn.tigris.org/"
+SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-freebsd ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc examples"
+
+RDEPEND=">=dev-python/pycxx-6.1.1
+ dev-vcs/subversion"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+src_prepare() {
+ # Skip test test-06 if executed as root to avoid failure.
+ epatch "${FILESDIR}/${PN}-1.7.1-skip_root_test.patch"
+
+ # Don't use internal copy of dev-python/pycxx.
+ rm -fr Import
+
+ python_copy_sources
+
+ preparation() {
+ cd Source
+ if has "${PYTHON_ABI}" 2.4 2.5; then
+ "$(PYTHON)" setup.py backport || die "Backport failed"
+ fi
+ }
+ python_execute_function -s preparation
+}
+
+src_configure() {
+ configuration() {
+ cd Source
+ "$(PYTHON)" setup.py configure \
+ --pycxx-src-dir="${EPREFIX}/usr/share/python$(python_get_version)/CXX" \
+ --apr-inc-dir="${EPREFIX}/usr/include/apr-1" \
+ --svn-root-dir="${EPREFIX}/usr" || return 1
+
+ sed \
+ -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
+ -e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \
+ -e "/^CCC=/s:g++:$(tc-getCXX):" \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -e "/^LDSHARED=/s:g++:$(tc-getCXX) ${LDFLAGS}:" \
+ -i Makefile || die "sed failed"
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ building() {
+ cd Source
+ emake
+ }
+ python_execute_function -s building
+}
+
+src_test() {
+ testing() {
+ cd Source
+ emake test || return 1
+ emake -C ../Tests || return 1
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ installation() {
+ cd Source/pysvn
+ exeinto "$(python_get_sitedir)/pysvn"
+ doexe _pysvn*$(get_modname) || die "doexe failed"
+ insinto "$(python_get_sitedir)/pysvn"
+ doins __init__.py || die "doins failed"
+ }
+ python_execute_function -s installation
+
+ if use doc; then
+ dohtml -r Docs/ || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc Examples/Client/* || die "dodoc examples failed"
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize pysvn
+}
+
+pkg_postrm() {
+ python_mod_cleanup pysvn
+}