summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-07-01 21:33:23 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-07-01 21:33:23 +0000
commit799cfc2774f9b95f761705a1b1920166a189a6ab (patch)
tree175267a59f7525f06d2faa5d3bda7414a5157243 /dev-python/pytest
parentRemove old ebuilds. Requested by Arfrever (diff)
downloadgentoo-2-799cfc2774f9b95f761705a1b1920166a189a6ab.tar.gz
gentoo-2-799cfc2774f9b95f761705a1b1920166a189a6ab.tar.bz2
gentoo-2-799cfc2774f9b95f761705a1b1920166a189a6ab.zip
Remove old ebuilds. Requested by Arfrever
(Portage version: 2.2.0_alpha42/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog6
-rw-r--r--dev-python/pytest/pytest-2.0.0.ebuild45
-rw-r--r--dev-python/pytest/pytest-2.0.1.ebuild44
3 files changed, 5 insertions, 90 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index 2abd855b9562..575135430c18 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.25 2011/06/27 15:20:20 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.26 2011/07/01 21:33:23 hwoarang Exp $
+
+ 01 Jul 2011; Markos Chandras <hwoarang@gentoo.org> -pytest-2.0.0.ebuild,
+ -pytest-2.0.1.ebuild:
+ Remove old ebuilds. Requested by Arfrever
27 Jun 2011; Brent Baude <ranger@gentoo.org> pytest-2.0.2.ebuild:
Marking pytest-2.0.2 ppc for bug 372595
diff --git a/dev-python/pytest/pytest-2.0.0.ebuild b/dev-python/pytest/pytest-2.0.0.ebuild
deleted file mode 100644
index 10d4e7904406..000000000000
--- a/dev-python/pytest/pytest-2.0.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.0.0.ebuild,v 1.8 2011/01/30 18:01:42 armin76 Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-RDEPEND=">=dev-python/py-1.4.0"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools"
-
-DOCS="CHANGELOG README.txt"
-PYTHON_MODNAME="pytest.py _pytest"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${P}-nose-1.0+python-3.patch"
-
- # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" "build-${PYTHON_ABI}/lib/pytest.py"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
-}
diff --git a/dev-python/pytest/pytest-2.0.1.ebuild b/dev-python/pytest/pytest-2.0.1.ebuild
deleted file mode 100644
index df5a8dea6d44..000000000000
--- a/dev-python/pytest/pytest-2.0.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.0.1.ebuild,v 1.7 2011/03/31 17:45:30 xarthisius Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-RDEPEND=">=dev-python/py-1.4.1"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools"
-
-DOCS="CHANGELOG README.txt"
-PYTHON_MODNAME="pytest.py _pytest"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" "build-${PYTHON_ABI}/lib/pytest.py"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
-}