summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-01 10:20:49 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-01 10:20:49 +0000
commit5d7b31c79190a92d2440a312a08ef46b99ee8e71 (patch)
treed33f811c7aae822ad5c898f64d1c2eddd3a41588 /dev-python/python-docs
parentbump; rm old (diff)
downloadgentoo-2-5d7b31c79190a92d2440a312a08ef46b99ee8e71.tar.gz
gentoo-2-5d7b31c79190a92d2440a312a08ef46b99ee8e71.tar.bz2
gentoo-2-5d7b31c79190a92d2440a312a08ef46b99ee8e71.zip
bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/ChangeLog7
-rw-r--r--dev-python/python-docs/python-docs-3.4.2.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/python-docs/ChangeLog b/dev-python/python-docs/ChangeLog
index bc77637d4f00..9ae3ad7fceac 100644
--- a/dev-python/python-docs/ChangeLog
+++ b/dev-python/python-docs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-docs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.197 2014/09/11 02:48:08 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.198 2014/11/01 10:20:49 idella4 Exp $
+
+*python-docs-3.4.2 (01 Nov 2014)
+
+ 01 Nov 2014; Ian Delaney <idella4@gentoo.org> +python-docs-3.4.2.ebuild:
+ bump
11 Sep 2014; Patrick Lauer <patrick@gentoo.org> python-docs-3.2.5.ebuild:
Mark python-docs:3.2 stable to silence repoman
diff --git a/dev-python/python-docs/python-docs-3.4.2.ebuild b/dev-python/python-docs/python-docs-3.4.2.ebuild
new file mode 100644
index 000000000000..ca335286cc02
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.4.2.ebuild,v 1.1 2014/11/01 10:20:49 idella4 Exp $
+
+EAPI="5"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="3.4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+pkg_setup() {
+ # Compatibility with Arfrever's pre-release ebuilds.
+ # Remove this in python-docs-3.4.1.
+ if has_version "=dev-lang/python-3.4_pre*[doc]"; then
+ rm -f "${EROOT}etc/env.d/60python-docs-3.4"
+ fi
+}
+
+src_install() {
+ dohtml -A xml -A inv -r ./
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+pkg_postrm() {
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}