summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-11-09 08:52:41 +0000
committerIan Delaney <idella4@gentoo.org>2013-11-09 08:52:41 +0000
commite747c44c41d522dd920bf7dbb895c56b4499192f (patch)
tree7d0f91d419dd71f6a3add61895eb289a6d21f11a /dev-python/python-keystoneclient
parentAdd missing PYTHON_REQUIRED_USE. (diff)
downloadgentoo-2-e747c44c41d522dd920bf7dbb895c56b4499192f.tar.gz
gentoo-2-e747c44c41d522dd920bf7dbb895c56b4499192f.tar.bz2
gentoo-2-e747c44c41d522dd920bf7dbb895c56b4499192f.zip
test phase re-invoked with known and filed failed tests excluded
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-keystoneclient')
-rw-r--r--dev-python/python-keystoneclient/ChangeLog7
-rw-r--r--dev-python/python-keystoneclient/python-keystoneclient-0.3.1.ebuild11
-rw-r--r--dev-python/python-keystoneclient/python-keystoneclient-0.3.2.ebuild11
-rw-r--r--dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild4
4 files changed, 20 insertions, 13 deletions
diff --git a/dev-python/python-keystoneclient/ChangeLog b/dev-python/python-keystoneclient/ChangeLog
index 8efa4cae0e1d..5d4bb5b6635f 100644
--- a/dev-python/python-keystoneclient/ChangeLog
+++ b/dev-python/python-keystoneclient/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-keystoneclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/ChangeLog,v 1.18 2013/11/08 03:38:03 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/ChangeLog,v 1.19 2013/11/09 08:52:41 idella4 Exp $
+
+ 09 Nov 2013; Ian Delaney <idella4@gentoo.org>
+ python-keystoneclient-0.3.1.ebuild, python-keystoneclient-0.3.2.ebuild,
+ python-keystoneclient-9999.ebuild:
+ test phase re-invoked with known and filed failed tests excluded
08 Nov 2013; Matthew Thode <prometheanfire@gentoo.org>
python-keystoneclient-0.2.5.ebuild, python-keystoneclient-0.3.1.ebuild,
diff --git a/dev-python/python-keystoneclient/python-keystoneclient-0.3.1.ebuild b/dev-python/python-keystoneclient/python-keystoneclient-0.3.1.ebuild
index 402b53631899..ec2a1b25279c 100644
--- a/dev-python/python-keystoneclient/python-keystoneclient-0.3.1.ebuild
+++ b/dev-python/python-keystoneclient/python-keystoneclient-0.3.1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-0.3.1.ebuild,v 1.5 2013/11/08 03:38:03 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-0.3.1.ebuild,v 1.6 2013/11/09 08:52:41 idella4 Exp $
EAPI=5
-#restricted due to packages missing and bad depends in the test ==webob-1.0.8
-RESTRICT="test"
+
#PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
PYTHON_COMPAT=( python2_7 )
@@ -51,8 +50,10 @@ RDEPEND=">=dev-python/d2to1-0.2.10[${PYTHON_USEDEP}]
PATCHES=(
)
-# "${FILESDIR}/0.2.3-CVE-2013-2104.patch"
python_test() {
- "${PYTHON}" setup.py nosetests || die
+ # https://bugs.launchpad.net/python-keystoneclient/+bug/1243528
+ # https://bugs.launchpad.net/python-keystoneclient/+bug/1174410; last touched on
+ # 2013-05-29 with 'importance: Undecided → Medium' and never worked since.
+ nosetests -I 'test_http*' -e test_auth_token_middleware.py || die "testsuite failed"
}
diff --git a/dev-python/python-keystoneclient/python-keystoneclient-0.3.2.ebuild b/dev-python/python-keystoneclient/python-keystoneclient-0.3.2.ebuild
index 59ad34cfe3fd..ab156572747f 100644
--- a/dev-python/python-keystoneclient/python-keystoneclient-0.3.2.ebuild
+++ b/dev-python/python-keystoneclient/python-keystoneclient-0.3.2.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-0.3.2.ebuild,v 1.2 2013/11/08 03:38:03 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-0.3.2.ebuild,v 1.3 2013/11/09 08:52:41 idella4 Exp $
EAPI=5
-#restricted due to shitty httpretty dep
-RESTRICT="test"
+#testsuite has unpretty httpretty deps
#PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
PYTHON_COMPAT=( python2_7 )
@@ -53,8 +52,10 @@ RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
PATCHES=(
)
-# "${FILESDIR}/0.2.3-CVE-2013-2104.patch"
python_test() {
- "${PYTHON}" setup.py nosetests || die
+ # https://bugs.launchpad.net/python-keystoneclient/+bug/1243528
+ # https://bugs.launchpad.net/python-keystoneclient/+bug/1174410; last touched on
+ # 2013-05-29 with 'importance: Undecided → Medium' and never worked since.
+ nosetests -I 'test_http*' -e test_auth_token_middleware.py || die "testsuite failed"
}
diff --git a/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild b/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild
index ebb16a9c4f5c..891342682cdc 100644
--- a/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild
+++ b/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild,v 1.7 2013/11/08 03:38:03 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild,v 1.8 2013/11/09 08:52:41 idella4 Exp $
EAPI=5
#restricted due to packages missing and bad depends in the test ==webob-1.0.8
@@ -53,5 +53,5 @@ PATCHES=(
# "${FILESDIR}/0.2.3-CVE-2013-2104.patch"
python_test() {
- "${PYTHON}" setup.py nosetests || die
+ nosetests || die "testsuite failed"
}