summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-28 20:04:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-28 20:04:00 +0000
commit924285aa221b77b7e861bac05366e5fd8224f69e (patch)
treeef3a79ecbf192d6215b9221edddce65453a0fe91 /dev-python/python-openid
parentDelete older ebuild. (diff)
downloadgentoo-2-924285aa221b77b7e861bac05366e5fd8224f69e.tar.gz
gentoo-2-924285aa221b77b7e861bac05366e5fd8224f69e.tar.bz2
gentoo-2-924285aa221b77b7e861bac05366e5fd8224f69e.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-openid')
-rw-r--r--dev-python/python-openid/ChangeLog8
-rw-r--r--dev-python/python-openid/python-openid-2.2.5.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-python/python-openid/ChangeLog b/dev-python/python-openid/ChangeLog
index cb99325ede16..df479355b7be 100644
--- a/dev-python/python-openid/ChangeLog
+++ b/dev-python/python-openid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-openid
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/ChangeLog,v 1.13 2010/02/08 08:49:17 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/ChangeLog,v 1.14 2010/06/28 20:04:00 arfrever Exp $
+
+*python-openid-2.2.5 (28 Jun 2010)
+
+ 28 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -python-openid-2.2.4.ebuild, +python-openid-2.2.5.ebuild:
+ Version bump.
08 Feb 2010; Peter Volkov <pva@gentoo.org> python-openid-2.2.4.ebuild:
Add inherit eutils for epatch.
diff --git a/dev-python/python-openid/python-openid-2.2.5.ebuild b/dev-python/python-openid/python-openid-2.2.5.ebuild
new file mode 100644
index 000000000000..0ede27890eee
--- /dev/null
+++ b/dev-python/python-openid/python-openid-2.2.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/python-openid-2.2.5.ebuild,v 1.1 2010/06/28 20:04:00 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="OpenID support for servers and consumers."
+HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/ http://pypi.python.org/pypi/python-openid"
+# Downloaded from http://github.com/openid/python-openid/downloads
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples mysql postgres sqlite"
+
+RDEPEND="mysql? ( >=dev-python/mysql-python-1.2.2 )
+ postgres? ( dev-python/psycopg )
+ sqlite? ( || ( dev-lang/python[sqlite] >=dev-python/pysqlite-2 ) )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/openid-python-openid-b666238"
+
+PYTHON_MODNAME="openid"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Patch to fix confusion with localhost/127.0.0.1
+ epatch "${FILESDIR}/${PN}-2.0.0-gentoo-test_fetchers.diff"
+
+ # Disable broken tests from from examples/djopenid.
+ sed -e "s/django_failures =.*/django_failures = 0/" -i admin/runtests || die "sed admin/runtests failed"
+}
+
+src_test() {
+ # Remove test that requires running db server.
+ sed -e '/storetest/d' -i admin/runtests
+
+ testing() {
+ "$(PYTHON)" admin/runtests
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}