summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-03-18 17:43:50 +0000
committerPatrick McLean <chutzpah@gentoo.org>2013-03-18 17:43:50 +0000
commit7e94353918f776602bd2a6efca07708f5dff967c (patch)
treefbad2cc8c0f4d6e73daea1fbfe1335fa4fa9b4f2 /dev-python/python-uinput
parentapp-office/texmaker: Add some more PREFIX love (diff)
downloadgentoo-2-7e94353918f776602bd2a6efca07708f5dff967c.tar.gz
gentoo-2-7e94353918f776602bd2a6efca07708f5dff967c.tar.bz2
gentoo-2-7e94353918f776602bd2a6efca07708f5dff967c.zip
New package, pythonic API to the Linux uinput kernel module.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'dev-python/python-uinput')
-rw-r--r--dev-python/python-uinput/ChangeLog9
-rw-r--r--dev-python/python-uinput/metadata.xml8
-rw-r--r--dev-python/python-uinput/python-uinput-0.9.ebuild28
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-uinput/ChangeLog b/dev-python/python-uinput/ChangeLog
new file mode 100644
index 000000000000..0f8fa6bfa683
--- /dev/null
+++ b/dev-python/python-uinput/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/python-uinput
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-uinput/ChangeLog,v 1.1 2013/03/18 17:43:50 chutzpah Exp $
+
+*python-uinput-0.9 (18 Mar 2013)
+
+ 18 Mar 2013; Patrick McLean <chutzpah@gentoo.org> +python-uinput-0.9.ebuild:
+ New package python-uinput
+
diff --git a/dev-python/python-uinput/metadata.xml b/dev-python/python-uinput/metadata.xml
new file mode 100644
index 000000000000..800a7133815f
--- /dev/null
+++ b/dev-python/python-uinput/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">python-uinput</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-uinput/python-uinput-0.9.ebuild b/dev-python/python-uinput/python-uinput-0.9.ebuild
new file mode 100644
index 000000000000..745858585f7b
--- /dev/null
+++ b/dev-python/python-uinput/python-uinput-0.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-uinput/python-uinput-0.9.ebuild,v 1.1 2013/03/18 17:43:50 chutzpah Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_{6,7},3_{1,2,3}})
+inherit eutils distutils-r1
+
+DESCRIPTION="Pythonic API to the Linux uinput kernel module. "
+HOMEPAGE="http://tjjr.fi/sw/python-uinput/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ fix_missing_newlines() {
+ sed -r -i 's/\)([A-Z]+)/\)\n\1/g' "${BUILD_DIR}"/lib/uinput/ev.py || die "sed failed"
+ }
+ python_foreach_impl fix_missing_newlines
+ distutils-r1_src_install
+}