summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-12-13 22:37:31 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-12-13 22:37:31 +0000
commit69a55b206579ed3b2cc75d83e7759ac67b5dea98 (patch)
treeb07fe401e11f5ce467ff2f13ddd5b596ea7afd76 /dev-python/pyxdg/pyxdg-0.19.ebuild
parentFix typo. (diff)
downloadgentoo-2-69a55b206579ed3b2cc75d83e7759ac67b5dea98.tar.gz
gentoo-2-69a55b206579ed3b2cc75d83e7759ac67b5dea98.tar.bz2
gentoo-2-69a55b206579ed3b2cc75d83e7759ac67b5dea98.zip
Version bump, bug #339009.
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyxdg/pyxdg-0.19.ebuild')
-rw-r--r--dev-python/pyxdg/pyxdg-0.19.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyxdg/pyxdg-0.19.ebuild b/dev-python/pyxdg/pyxdg-0.19.ebuild
new file mode 100644
index 000000000000..2098c7a9587a
--- /dev/null
+++ b/dev-python/pyxdg/pyxdg-0.19.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxdg/pyxdg-0.19.ebuild,v 1.1 2010/12/13 22:37:31 eva Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="A Python module to deal with freedesktop.org specifications"
+SRC_URI="http://people.freedesktop.org/~lanius/${P}.tar.gz"
+HOMEPAGE="http://pyxdg.freedesktop.org/ http://people.freedesktop.org/~lanius/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="xdg"
+DOCS="AUTHORS"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-subprocess.patch"
+}
+
+src_install () {
+ distutils_src_install
+
+ insinto /usr/share/doc/${PF}/tests
+ insopts -m 755
+ doins test/*
+}